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MPLAB leírás V1.1 
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 �������  ��	�
számára. Nem helyettesíti a kézikönyvet, és nem törekszik a teljességre. A menükkel való ismerkedésnek a 
legjobb módja, azok kipróbálása. Feltételezzük továbbá, hogy az olvasó jártas a Windows alapú környezet 
��
����������! "� �� ����
 �� ��	�	 �����
 ��
# �� �$ #�%�
���
���� ���������	! � �������
��& �� '������
projektszemlélet, és az ICD (In-Circui� (��)

��* ���
� ����#�
 ��+
� �����
��	 �
���� �����-ba 
illesztése. 
 
�� ����� � �,- �������������� ��� ���
��#�� �����
��	 �
�����! Tartalmaz egy ��������������	
	 (editort ) a 
programok megírásához, assemblert a programok fordításához, szimulátort a programok teszteléséhez, valamint a 
�
��	��	 ���� ���	
 �����
���������	, amivel a fejlesztett program a EPROM-os vagy OTP-
 �,- ����� �� 
�����	. A 
progam a PICmaster emulátort és egyéb eszközöket is tudja kezelni, a leirásban  az ehhez kapcsolódó részek 
kimaradnak. Az anyagba bekerült ellenben az olcsó MBLAB-��� �����	
�� 
�	
��������� �����	�� 
Az ilyen, „mindent az egyben” típusú programot szokták ��	�����	 �������	
 környezet-nek (Integrated Developping 
Enviroment = IDE ) is nevezni.  
Az MPLAB parancsainak k��%�
��� ����# �����	
 
.�� ���& 
 

• � #��.���%
����	� ����
���)� ��� 
• � ������)� ���%��� ��������$��#����+��� ��
�����)�� 
• �� �
������� #�
�����	 �������� ��������� ����������)�! 
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A File #��.���� � 
����
�
 ����#$������� /Save (=mentés), Save 
as...(=mentés másként) ,Save All (az összes megnyitott fájl mentése), Close 
(=bezárás) , Close All (az összes megnyitott fájl bezárása), mellett a 
��������	 #$��������� �
 �����
����& 
New Source - Új forrásfájl készítése 
Open source- #�
� �	 �����
���� #�
�����
�! 
Megjegyzés: a fenti két menüpont segítségével a projekten kívüli fájlok 
��
���	��� ������ ��
���	��� 
View  - a kiválasztott fájl megnézése. 
Import  - Download to memory .HEX kiterjesz� 
$ ����� �)%)�� ������� ��!
��  
��	 ���
��# � 
� �� 
Export   

• Save Trace Buffer:� ���#����� 
 /�%! � 
	��* ���%# �� �
menthetjük fájlba pl. további tanulmányozásra  

• Save Hex File: a lefordított programunkat menthetjük el Intel 
hex formátumban  

Print  - A kiválasztott fájl nyomtatása 
Print Setup - Nyomtató beállítás 
Az utoljára használt fájlok listája van a menüpont végén. 
 

 Projektek kezelése 
 
0����
 �����#�	�� �� ����-nek a projekt koncepció: ez azt jelenti, hogy egy adott fejlesztéshez tartozó fájlokat egy ún. 
������� ������� ������������)�! 1� ��� � ����� #�
�����)�� � �������������� ������ � �����
�� 
��� ������� ������	%���  

használhatók. A Project menüvel lehet a projekteket kezelni.  
Ez a menü - amióta lehetséges különféle forrásból származó fájlokat összekapcsolva (ez a linkelés) egy összetett .HEX 
fájlt létrehozni - összetettebb lett. 
Az MPLAB-ban a projekt egy projekt objektum (ez a node, azaz csomópont)  egy vagy több forrás objektumból (node-
ból) épül fel. Ezek a források általában MPASM assemb���� ������� #�
�
 
����$ - ��
� ��2,- �����
������� ��	��
�����%����� ������� ������� #�
 ���
���%�� /����+� ������*� ������� �� ���� �

�����+
���
�� � 
�	 linker script ��� ��	
szövegfájlok (hasonlók a DOS batch fájljaihoz).  
Általában a projektet ugyanabban a könyvtárban helyezzük el mint a forrásfájlokat. Linkeléskor az  összelinkelni kívánt 
ún. object fájlokból hozzuk létre a végleges lefordított  tárgykódot, vagyis egy .HEX fájlt ilyen node-ok építik fel. Egy 
node egy forrásprogramot és egy fordítóprogramot (BASIC, C) vagy assembler programot is meghatároz ezeket hívjuk 
nyelvi eszközöknek ( Language Tool = Nyelvi eszköz).  
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Mi a továbbiakban (mivel ez a leírás az MPLAB-al 
�
#���%	���� 
���*� +
)��� �� ���� �����+���
létrhozásának lépéseit írjuk le, amely egy MPASM 
forrásfájlt tartalmaz. A gyakorlatban is ez a 
��
����
��� ��	���%)�� �
��! 

 
1. Új projekt létrehozásakor��	
��� � ���
��# �����sztési módját, és a használt PIC processzor típusát kell megadni az 
Options>Development Mode  menüpontban.   
�� ������ ����
���
� �����	
 
��& 

 
• Editor Only  - ezt választva csak program írásra és fordításra 

��� �����	
 
  
• MPLAB-SIM - Simulator ezt kell használni �� ���+
 �.�
	

eszközünk 
• MPLAB-ICE Emulátor  
• PICMASTER Emulátor  
• SIMICE Simulator  
• ICEPIC  
• MPLAB-ICD Debugger - �� �� '� �����	
 
 3 
 
A megadás után a RESET-re kattintva történik meg a kiválasztás. 
  
 
2. Utána a Project>New Project menüpontnál kell megadni a  

projekt fájl nevét (pl.: minta.pjt), és a könyvtárát, ahol el fogjuk helyezni. 
 
3. Ezek után az Edit Project �����
� %�
 %���� �������� #�
� ���� � ����� � �	 Project Files ablakban már látjuk a 
minta[.hex] bejegyzést. (Itt adhatjuk meg az Include, Library és Linker Script fájlok útvonalát, változathatjuk meg a már 
beállított fejlesztési módot, kontroller típust, valamint a használt nyelvi eszközt (fordító, vagy assembler programot)). 
 
4. Ha rákattintunk a minta[.hex] bejegyzésre, megjelenik a NODE Properties párbeszédes ablak,  ahol megnézhetjük 
illetve átállíthatjuk a nyelvi eszköz beállított alapértelmezéseit:  
 
Kiválaszthatjuk a programozónak vagy a szimulátornak szóló kimeneti hex fájl formátumát (Hex Output). Generáljon-e 
az assembler hibaüzeneteket tartalmazó  fájlt  (Error file ), a forrásnyelvi kódot és a hozzá fordított gépi kódot 
tartalmazó lista fájlt, illetve kereszt referencia fájlt (ez azt tartalmazza, hogy a használt szimbólumok melyik program 
sorokban találhatók.) Mikor nyissa meg a hiba fájlt megtekintésre: csak a hibáknál - hibáknál és figyelmeztetéseknél - 
bármilyen üzenet esetén. �
���� � ��������� ����������
���� ��������		�� ������ ����������� ���� � ����
�� ��������  !��� �	

jelez, bár a beállításokat eleinte nem érdemes változtatgatni. 
 
Az OK-�� ��������
 )��� �� ��	�	 Edit Project �������� �� ��	�	��
 
�.��� / 
 ����� #�%�� ��m kiválasztható) Add 
Node gomb kivilágosodik, és rákattintva hozzárendelhetjük a minta.asm fájlt. Természetesen ennek a fájlnak már 
��	�	��
 � ������ ���� 333  (���� �� ��
	��� #�
�%��� ������� ���� ��� � #�� �����
�� �� �� #���� �%�)� #�
 #����!���
néven).  "� ��� ������� ��
� '� ������� �
�� � ��	
��� �
� �2� ����� ���� � �������)�� 333 
 
Egy új forrásfájl létrehozása a File>New menüpont segítségével lehetséges. 
 
5. Ezek után a Project>Make Project menüpont aktivizálásával létrehozható a tárgykód. 
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A p����+� ������ 
����
�
 ����� 
� �����	
 
��� ��# � 
�������.�! 
 
Az Edit Project menüpontban szerkesztjük meg a project fájlokat. 
A Make Project segítségével elvégezzük az assemblálást az MPASM 
segítségével.  
Build All menüpontot aktualizálva a projekt újrafordítása történik meg. (Ez 
"�� ��������� 
!�� � 	
���#���!��� ��������
# ��$� �������	
��	% ����

�����
!
�	� ���&!����� 
�	!������ � &�!���� ��'� �	 �()* �������	
��	%

fájljaihoz. Ha a .COD régebbi mint a hasonlított fájlok valamelyike, 
+ ��#	
��%��� �#�osítva lett) akkor elvégzi az újrafordítást.) 
A Build Node menüpontot használhatjuk egy forrásfájl lefordítása projekt 
környezet nélkül. Ehhez minden projektet be kell zárni, majd a File>New 
vagy File>Open menüpontokkal létrehozott illetve beolvasott fájlt Build 
Node menüponttal  lefordítjuk. 
Az Install Language Tool… segítségével új fordítót (pl. C, BASIC) 
illeszthetünk az MPLAB környezetébe. 
 

�����������	
�����
�������� 
 

�� ����� 
����

�����
��	�� � ���
 ��� �
� ����
�
 4��%�5
 ����'

����

�����
��	� de olyan részekkel lett kiegészítve, amelyek a programok 
megírását megkönnyítik 
�� "%�� #��. �� ����� 
����

�����
��	� ��� ���+
���%��!  
Undo   - )���
� 
�����
��	 #$����� ��

������
�� 
Cut   - kijelölt rész kivágása és a vágólapra másolása 
Copy   - kijelölt rész vágólapra másolása 
Paste   - a kurzorral megjelölt helyre a vágólap tartalmát másoljuk  
Select All - a teljes szöveg kijelölése 
Select Word - annak a szónak a kijelölése, amelyiken a kurzor áll. 
Delete Line - a kurzort tartalmazó sor törlése 
Delete EOL - a kurzorpozíciótól  kezdve s sor végéig a törlés 
Goto line - ugrás adott sorszámú sorra 
Find   - keresés 
Replace  - keresés és helyettesítés 
Repeat Find - ismételt keresés 
Repeat Replace - ismételt helyettesítés 
Match Brace - �� � ���%	 ��������� ���)�� � �)�������� ����� � �����+
  


�
��
 
 ��� #�
����
����.� � ����� ������� �������	  
  zárójelet  

Template - segítségével létrehozhatunk, kezelhetünk olyan 
állományokat, melyben a gyakran használt szövegrészeinket  
tárolhat�)��  
 � �����
���
��#���� 
����
 #�
�����	 ���� ��
������� � �)����� ������ � 
����
� 
����� ��	�������)�  
 �  

szövegbe illeszthetjük. 
����������	
����
�����
�	
���
���������	�	��������
�����
� 

�	����������	
	���
	�	���
�
�
���������� 
�����������	
	��tja a kijelölt szöveget 
Bekezdést növel a kurzorral kijelölt sorban 
Bekezdést csökkent a kurzorral kijelölt sorban 

 

Az MPLAB szimulátora 
 
� 
��#)����� ���
��# ���� 
���
��� ��
� � �,- #������������������ ��� ���
��#�� �����	����� #�%�� ����

��
végrehajtani. Ez azt jelenti, hogy a program végrehajtása közben: 
 

• meg tudjuk vizsgálni és esetleg módosítani a kontroller bármelyik regiszterének tartalmát (watch),  
• meg tudjuk a program futását adott helyen állítani, azaz töréspontot tudjunk elhelyezni (breakpoint), 
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• tudjuk a programot lépésenként futtatni (single step), 
• � �.�
	 ����������	� ���	 /���)�* �%������ ������� ������
�� 
��#)����� /
��#)�)
*� 
• illetve kiküldött (output) adatokat fájlba eltárolni, 
• � 
��#)��+�� 
���� ����������	 �
�# ������ � � 
	��� ���#� 
 + ������ 
�$����� /���+�*! 

 
A Debug menüpont az MPLAB legfontosabb része. Segítségével lehet a megírt programunkat tesztelni, szimulálni. 
6����
��	 ������� ����� ��	���������  
 � ����
)��� 
 
��#)��+����� ���#�� �������! 
 
A felhasználónak a program belövé
� 
���� �
�� ��
� 
�
��
 
�� ��'��� �� � ���
��#�� �
�� # 
 �� ��%���
 ��	�� ��������
címeken meg lehet állítani, azaz a futását felfüggeszteni. Ekkor ugyanis a regiszterek és a programban  használt változók 
������#����� ���

�������� ������� ��%������	� ��
� � ���
��# �%%�
 � �����
 �����
��� ��
� ����
�� #$��%���! �
�����
 ���
��#�� ����� ��
������
 ��� ���������� � 
��� ������� � ����
�� #$��%	 ���
��#� 
� 
���
�� #�
�����������!
Az ilyen leállási feltétel--azaz töréspont (angolul breakpoint (e.: brékpoint)--� ���
��#��� ���� �
 �����������	!  
�� �
 �����
 ����� ��
� �
� ���
��# 
��#)����
� ������ � �)��
 
���� � ��
����� ��
�
�������	�� ���� ������#����
�%������ 
�$��
.��! "� � ���#����� 
� ��
� #�
 � ��� tracing. 
 
A lépésenkénti program végrehajtás (Single Step) üzemmódban a felhasználói programnak mindig csak egy utasítása 
�����%�� � 
���  
 �������� #��%�
 �����	
 
 ��� � ��
�
������ ��
� � ���������#�� ���

�������� ��
��
 � � 
���������
)��
���
 ����
����� � ���
��# �����
 #$��% 
 ��� �� �����	�� 
 ��! �����	
 
 ��� 
�)��)����� �
� � � 
��� ���� �	
végrehajtására is. 

 
 
A program futásával kapcsolatos tevékenységeket tartalmazza 

Execute an Opcode - Egy beírt utasítást végrehajt 
Conditional Break  - �%! � 
	�� 

Simulátor Stimulus azaz a Gerjesztések - ld. lent 
Az aktuális programszámlálóhoz tartozó programrészletet a 
� �����	 ����� �� ��
�� 
Töréspontok beállítása 
Nyomkövetés beállítása 
Emulátorhoz.... 
Minden törés- és nyomkövetési pont törlése 
  

A program memória törlése 
Mintha az MPLAB-ot újra indítottuk volna 
Mintha a kontrollert éppen bekapcsoltuk volna.. 
 

A Run menüpont részletesebben:  
 

A program futtatása 
Alaphelyzetbe állítás, programszámlálóba nulla kerül 
A futó program megállítása, programszámláló megáll 
Nyomkövetés megállítása, de a program továbbfut 
����	��� �	���!��������������������������
 �"
��
���	�������# 
Lépésenkénti program végrehajtás 
Lépésenkénti futtatás, a rutinokat egy lépésben hajtja végre. 

$����������������	���	
���
��	�	���!������ 
Az utasításszámláló megváltoztatása 

 
Conditional Break (Feltételes töréspont) 
 
A menüpont aktivizálásakor egy dialógusdoboz jelenik meg, amivel automatikus lépésenkénti programvégrehajtást 
indíthatunk.  Akkor áll meg a program futása, ha valamelyik megadott feltétel teljesül., (vagy a Halt gombot nyomjuk 
meg...*! � %����
)
%������� 
������	 ���#�� #�
��������& 
 

• Single Cycle  - � ���� ���� #��%�� )��
���
 � 
�������
���� �����	���! 
• Multiple Cycles - � ���� ���� +
�� � ���#��� %�������� ��� 
������ �� � 
���� �����	��� 
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• Update Display - a feltételes töréspontot vé
��������� %� � %�
�

�#����� ��
��� ������#��� � �����	� ��#
frissíti 

 
� ��������	 #�
����
� ���� ����� ����
�������& 
 

User Halt - Halt gombra áll meg meg a futás 
Number of Cycles - adott számú ciklus után áll meg 
Register Value Conditions 

  Valamelyik fájlregiszter tartalmát hasonlítjuk egy konstanshoz ( ==, <>, >, <, >=, <= ) 
  Meg kell adni a regisztert ( pl. 02ah) és az értéket (pl. 33h) 
 

• Trace Data - A kiválasztott regiszterek tartalma minden alkalommal amikor a processzort leállítjuk, egy 
listába kerül, ahol látható lesz. 

• Edit  - itt lehet az��	�� �#������ ��
�
�������� ������
����� 
• Start - lépésenként hajtja végre a programot 
• Halt  - a feltételes törésponti végrehajtás megállítása 
• Reset - processzor alapállapotba állítása 
• Break Setting - Töréspont beállítási dialógus ablak megnyitása 
• Save Buffer - a törésponti tároló tartalmának *.TB fájlba mentése 

 
 
A lábakra adható gerjesztések (Stimulusok) 
 
� 
��#)��+�� 
���� � ��
�������� ����%�� � �.�
	 ��������� ��
����#�� � ����! � �.�����

�� ���� ���+
����
szimulációjának megvalósítására az MPLAB több�����	
 
�� �
 ��������& 
 
Aszinkron stimulus : 2�
��
 
 ��� � 
��#)���� ���������� �������� 
����
�� 
���� ���%��.���  
 ������ � � �����	� � �	
nyomógombsor segítségével aktivizálhatjuk. Egy gombhoz hozzá kell rendelnünk a lábat, és a gerjesztés típusát: 

Low - a gomb megnyomásakor alacsony 
szint lesz az adott lábon 
High - a gomb megnyomásakor magas 
szint lesz az adott lábon 
Toggle - a gomb megnyomásakor az adott 
����� � �	 
���� ������ � �� ���� 
Pulse  - a gomb megnyomásakor egy 
impulzus jelenik meg az adott lábon 

 
 
Az aszinkron stimulust csak a program futása közben használhatjuk! 
 
Pin stimulus : Egy szöveges ún. stimulus fájlban adhatjuk meg, hogy adott cikusszám után milyen legyen az adott láb 

����
�� 
�! � ���� ��
	 
������ 
������� � 27"� 
��  
 )tána a szimulált lábak szabványos megnevezése: 
 
STEP RB3 RB0 
 4 0 1  
13 1 0 
 
Azaz a 4. ciklusban RB3 lábra 0 RB0-ra 1 kerül, míg a 13.-ban RB3 lesz 1 és RB0 pedig 0. 
 
 
Clock stimulus: 
 
"
� ,89 ������ �
# ��	%	 �����%��)
 � 
�
��
����� ���%��.��& #�
 ���� �dni hogy hány ciklusig legyen a láb állapota 
#�
�
 /��
�*�  
 ���� +���)
�
 ���+
��� /��5* 
����$!  
 
A ciklusszámot decimális számként kell  megadni. 
 
 



 MPLAB leírás - dr. Kónya László 6  
 

 

 
Az Invert bejelölésével a jel ellentétes lesz 
/���+
������ ���%*! �� ��
� 
����� � �	
menüpontokkal több gerjesztést is használhatunk 
egyszerre (Add), törölhetünk közüllük (Delete), 
fájlból tölthetjük (Open)  fájlba menthetjük 
(Save), a dialógusdobozt bezárhatjuk (Close), a 
kiválasztott jelet aktvizálhatjuk (Apply ).  
 
 
 
 
 
 
 
 
 
 

 
Register Stimulus:  
 

Mikor a szimulációban egy megadott címre érünk, egy megadott 
regiszterbe egy szövegfájlból egy adott értéket töltünk. Ha többször 
����%)�� �� �� �%��� +�#��� ����� � ������� 
������	 �
�#�
 )����
 �� ��� 
����� �
�#�
 )��� ������	%��� � ��
�
������! �� �����
például az A/D átalakítás „eredményét” felhasználhatjuk, az 
ADRES regiszterbe a 0x56-os címet elérve a proba.reg fájlban 

������	  �� ��� /��! :;<<* ����� � 
��#)�����! 
 
 
Töréspontok beállítása 

 
 
 
 
 
A maximum 16 töréspontot a  dialógusablak 
segítségével adhatjuk meg. A töréspontnak nevet 
adhatunk (Title ). Beállíthatjuk a törésponti 
�����#��� ���%	-  
 � 
+�# � /�� � ����	 �����
�
akkor tényleg töréspont).  
Address is Qualifier - Ha töréspont létezik, 
akkor törésponti címhez megadhatjuk (Pass 
Count), ��
� ����
���� ���� +�#�� ���� �	
átfutás után álljon meg a futó program  
Break on Trace Buffer Full - a program futása 
megáll, ha a nyomkövetést tároló puffer 
#�
������ /= �*! "#)�������� �.�
	 �
�# �� �


okozhat törésponti megállást (Enable External Break,  
 �� ������ � �	 ������*! 
 A definiált töréspontokat mint a projekt része az MPLAB automatikusan elmenti kilépéskor. 
 
Nyomkövetés beállítása: dialógusdoboza majdnem azonos a töréspontiéval. Hasonló módon adhatjuk meg azt a 
címet illetve tartományt, amely elérésekor a nyomkövetés adatait tárolni kezdjük a töréspont pufferben.   
 

 Picstart Plus programozó 
 

A Picstart Plus programozó segítségével tudjuk a fejlesztett programjainkat EPROM-os vagy OTP-s tokba írni, és a 
valódi hardver környezetben kipróbálni. A programozó minden PIC kontroller írására képes, az újabb típusok 
megjelenésekor a MCH,� �%�� ��� � !1"> �������
�� 
$ ������ �#����� �
� �,-<?-@@-es tokba írva, a programozó 
aktualizálható (upgrade).  

 

A láb kiválasztása 

Töréspont eltávolítása 
 

Az összes töréspont eltávolítása 

Az összes töréspont kikapcsolása 

���%	+�# 

végcím 

A gerjesztéseket tartalmazó fájl  keresése. 

A töréspont neve 
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� ���
��#���� � 
��#���
 � ����#����� 
���
 �������� ���� +
������������! � ���
��#���
 
���� �� ����� ���
	
memória pufferének tartalmá� ���)� � ���
��#������ � �	 ������ � ���������� �����
)��+��
 �������� �
�.��! � �)�����
vagy egy fájlból töltjük fel (File-> Import ->DownloadToMemory), vagy az assemblálás során keletkezik. A 
programozóval pufferbe beolvasott PIC tok tartalmát fájlba is menthetjük (File->Export->Save .HEX file) 

 
 
A programozó engedélyezése 
 
%����	&���� �	�������!����	&��

�������� 
A programozóba helyezett PIC tok olvasása 
A tok ürességének (memória + konfigurációs bitek) vizsgálata 
OTP tok ürességének vizsgálata 
A progra&������	����

��������������������'�����&�������� 
 
A program memória puffer törlése 
Konfigurációs bitek törlése 
 
Programozó alaphelyzetbe állítása 
 

 
Az Intel hexa formátum 

 
Az Intel hexa formátumnál az adatokat rekordokba szervezik. Egy rekord változó hosszúságú lehet. 
� �����%��� �� ��
	 #��	 � ����������
 ���
 ������� ���� �
��� ! "� � #��	 ����� � �����% ���%�� �  
 �
� �2-,,
����	
������ ������#�� /&*! 
� #�
�%�� #��	 � ������"���� ���
 ������� #���	" �
��� ! "� � #��	 � � �2-,, ��������� ������#��� #���ek jelzik 
� �����%��� � �	 �%�������� 
��#��! � ��;�%�+�#���
�� �%��� �%�������� 
��#�� � � �2-,, ��������� �����������
�%�%�� �� � #��	 � � ���������� � #�
�
��� ����� �� �$ %�
�� 
������� ��	��! "
� �����%��� #�;�#���
�� ABB �%������
lehet. 
A harmadik #��	 � $�	��	��
 �%� ���
 �#��� &������ �
��� ! "� � #��	 � 
� �2-,, ��������� ������#��� � �����%
��;�%�+�#���
�� �%��� ������ 
� +�# ��� �2-,, ��������� ����������  �� � � �� ������ 
�����%���& � +�# ���
	 ���������
#�
�
��� ����� �� �$ %�
����� � +�# ���
	 ��������� ���+
������ ����� �� �$ %�
����� � +�# ��
� ��������� #�
�
���
����� �� �$ %�
����� � +�# ��
� ��������� ���+
������ ����� �� �$ %�
����! � �����%��� � �	 ��
	 �%������ � ������ 
� +�#��
����	%��� �� )���� ��������	 �%�������� � 
����� ��������	 +�#����! � ����� 
� /"�% 9� 0���� "90* �����%��� �� �
#��	 � 
� �2-,, �)���� ������#�� ��
� � ���
��# ���%	+�# �! 
� ��
��%�� #��	 � ������ 	%��� ���
 (Record Type Field). A rekord típus adatrekord esetén 00, fájlvége rekord 
�
�� � :<! "� � #��	 � � �2-,, ��������� ������#��� � �����% ���)
 �2-,, ������������ � #�
�
��� ����� �� �$ %�
��

������� ��	��! 
�� ���%�� #��	 �� ���	 ���
 �'�	� �
���*! "� � #��	 ������#���� �� ���)���
 �%������ � �-két ASCII karakterré 
������������ � #�
�
��� ����� �� �$ %�
�� 
������� ��	��! � ����� 
� �����%��� ���+
 �%�� #��	! 
�� )���
� #��	 �� �����
��
 ������ ���
 �("������ �
��� ! �� �����	��	 �

��
 � #�
�%��� ���#�%��� ��
��%��  
 ��
���%�� #��	 ��;�%�+�#���
 ���������� = ����� +
�������� �

��
 ��� �����
 ��#���#��
�! Az így kapott összeget két 
�2-,, ��������� ����������� ����)� � #��	 � � �������� �� � #�
�
��� ����� �� �$ %�
�� 
������� ��	��! 
� �����
��� �
 �������� ��
� �
� ,���� ��;� ���#��)#' ���� �
� 
����
�
 /�2-,,* ����� �
� ��! �
� 
����

�����
��	 ��
�
listázó program segítségével megvizsgálhatjuk a tartalmát. Példa Intel hexa formátumra: 
:10200000455A5420455244454D455320564F4C5453 
:0B201000204D454746454A54454E49C7 
:00000001FF 
� �����
��� ���+
���%��� �� ��
	 
�� #��	�& 
1. 2. 3. 4. 5.    6 
: 10 2000 00 455A5420455244454D455320564F4C54 53 
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Opciók 
 

Az Opciók menüpontban az MPLAB beállításait tudjuk megnézni, illetve módosítani. 
 
 
Fejlesztési mód: csak editor, vagy szimulátor (vagy emulátor...) 
A beállított ablakkonfigurációt tudjuk elmenteni 
 
Alapértelmezés szerinti  szerkesztési beállítások 
Aktuális szerkesztési beállítások 
Szerkesztési mód alaphelyzet  
 

(������������'�����

�������&������)������
��� 
 

MPLAB környezeti beállításai 
Színbeállítások... 
   

Processzor  
Programozó típus választása 

 
A Development Mode ablakot a projekt létrehozásakor a leírás elején már megmutattuk. Összefoglalva, az MPLAB 
több fejlesztési módban képes dolgozni: csak editort használva lehetséges programírás és fordítás. Szimulátor módban 
lehet a programot szimulátoron futtatni, és lehetséges emulátor alkalmazása is. Mindezen üzemmódok kiválasztásánál 
���� /�������	* #�
�%�� � ��
��ált processzor típusát is.! 
 

Ha az ICD-t használjuk, akkor a 
Options>Development Mode  párbeszéd ablakban a 
MPLAB-,-( (��)

�� ���$ 
�#����  
 � �,-<C0=??
���������� ���)
� ���� ����������! 7��# 
����
�� ��	
���
a debuggert soros porton kell csatlakoztatni, majd a 
#�
�����	 -9� ������  
 �%���������� 
���

 
�� /��!
192000) is be kell állítani. Ezek után a a Reset-re 
��������� �� ����� ,-( #$��% 
�� � 
�� /��
esetleges hibákról itt nem írunk…) és megjelenik az 
MPLAB-ICD párbeszéd ablak. 
� ���
	 ������ � a PIC-���� �
#��	���� �
� ����#$�
lényegében az emulátorban használt 16F877 tok  
konfiguráása. 

Az ICD állapota, alatta balra a soros port és sebesség. 
Órajel sebessége 
 
 
 

���� ����� �	
���� 
�������� �		������� ���	�� ��� ������� 
 
 
Szövegszerkes�	
 $����%	���
 
    
Megadhatjuk, hogy a Default Editor Modes� ���� � 
����

�����
��	 ��������
�� #����� �������� ��
���  �� ���
&
#�
�%��� �������
�� 
$ �������� /0��� 7���*�  ���� ������ �� /9���� 7���
*� ������� +
�� �� '� �������� /D�5 0���
*! 
 

 � ����� ���
��# ��������	 �

��
�  

tokazonosító megadása 

Mit olvasson fel a tokból lépésenként. (vigyázat 
az itt látható az alapértelmezés, és ez nagyon 
lelassítja a futást! 

Programozási paramétere�*�&����
-     
meddig, és mit programozzunk? 
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KIJELZÉSI - BEVITELI MÓD 
Auto Indent  - automatikus bekezdés: az új sor 
�������� ��
 ������� ���%	%�� #��� �� ��	�	 
Strip Trailing Spaces - � 
�� � 
 � � �	
������ 

�� '
� 
�# ���� ���$������� ����
�� ��
Enter-t ütünk a sor végén  
Show Line Numbers  - a sorok számozva 
��
���� � � �����	� 
Overwrite  - felülírás üzemmód  
Language - programnyelv választása 
EF�"GDHI 09G�JKJ2 
Tab Size - a tabulátor szélesség megadása 
/���� ���$���� ������* 
Soft Tabs - 7�� ����
��� �%��� 
��#' ���$����
helyettesít a TAB karakter helyett 
Wrapping Enabled - sortörés adott sorhosszt 
elérve automatikusan megtörténik  
Wrap Column - hányadik oszlopnál legyen a 
törés  
NYOMTATÁS 
Page Headers - új lap tetejére kiírja a fájl nevét 
, az oldalszámot és a dátumot. 
Wrap Long Lines - a hosszú sorokat 
nyomtatásnál eltöri 

FÁJLOK KEZELÉSE: 
Read Only    A betöltött fájlok nem módosíthatók, csak olvashatók. 
Backup When Saving Másolatot (backup copy) készít mentéskor az eredeti fájlról. 
Save at intervals A fájl adott tartományát menti. 
Strip Ctrl+Z On Load  Betöltéskor automatikusan a Ctrl+Z k�������� � ���� � 
 �	� ����
��! 
Add Ctrl+Z On Save Mentéskor automatikusan a Ctrl+Z karaktert a fájl végére írja. 
No EOLN after last line Utolsó sor utolsó karaktere után sorvége jelet ír mentéskor a fájl végére. 

 
Környezeti beállítások:� � �����	� ��
znált font 
típusa adható meg. Az eszközsáv (Toolbar) 
engedélyezése (Enable), és ha igen akkor a 
� �����	 #����� � 
� � ��
���! �� �
����
����
(Edit, Projekt, Debug és User) testre is szabhatók 
(Toolbar Setup). 
Status Bar Enable - � � �����	 ����� � �	 
���usz 
sor engedélyezése 
Clear Memory on Download - az emulátor 
#�#������� ������ 
 ��	�� ����� /#��%�� ��� <*! 
Clear Breakpoints on Download - az emulátor-
�� ���� ������ 
 ��	�� #��%�� ��� 
�������
nyomkövetési pontot töröl. 
Load Default Configuration  - az, MPLAB az 
alapértelmezett felhasználói ablakbeállításokat  
tölti be. Ennek megváltoztatása az Options > 
Window Setup > Save Setup menüpontban 
lehetséges. Az MPLAB.CFG az alapértelmezett 
felhasználói konfigurációt tartalmazó állomány. 
Global Break Enable - Ha nincs kiválasztva 
nem engedélyezi a töréspontokat. A státusz sorban 
is be- illetve kikapcsolható (a kurzorral ráállva. 
dupla kattintás a bal egérgombbal). 
Track Source Code - A forráskód aktuális sorát 
frissíti lépésenkénti programvégrehajtáskor.  

A regiszterek és a címkék kijelzésénél meg lehet adni azt hogy azok mennyi helyet foglaljanak el. 
 
 



 MPLAB leírás - dr. Kónya László 10  
 

 

Tools (Eszközök) menüpont 
 

 
 
DOS parancs kiadása a futó MPLAB alól. 

Ismételt parancskiadás 
 

+&�
������

�������� 
Emulátor csatlakozófej (Probe) konfigurálása 
 

Windows 
 
 
Program memória megjelenítése 
Nyomkövetési adatokat tartalmazó memória megjelenítése 
EEPROM memória TARTALMÁNAK megjelenítése (16X84) 
Teljes listafájl megjelenítése 
 

Veremtartalom megjelenítése 

Fájlregiszter - tartalom megjelenítése 

Speciális funkciójú regiszterek megjelenítése 

Használt szimbólumok listájának a megjelenítése 

Stopper... 
Projekt ablak megjelenítése 
 

A felhasználó által szimuláció közbeni megfigyelésre kiválasztott regisztereket 
tartalmazó ablak létrehozása, illetve a már létrehozott(ak) betöltése 
Módosítás 
  

Ablakok vízszintes elrendezése 
��
	�����,���
������
��������� 
Ablakok egymás mögötti elrendezése 
Ablakok ikonokká zsugorítása 
Ikokonok rendezése 

 
7��
�	��
�
 ���
��#� 
���� �%	���� � 
�������
�� ���������.� ���#��!
Megadhatjuk a szimulált processzor órajelét (Target Frequency) és 
mértékegységét. 
A Zero gombbal nullázhatjuk a stoppert. 
Kijelzésre kerül a nullázás óta végrehajtott ciklusok ( a legtöbb esetben egy 
utasítás az egy ciklus) száma (Cycles* � ������� �� ������ �%	 /Time). 

 

Segítségével memóriaterületek (Data, Stack, Program, illetve EEPROM) 
tartalmát módosíthatjuk. 
"���� #�
 ���� �%�� � #�%�
����%� ���.��� ���%	 /Address) és esetleges 
végcímét (End Address) . Címként hexadecimális szám (Radix:Hex),  
vagy decimális szám (Radix:Decimal), illetve címke is megadható.    
Data/Opcode #��	 -   Read gombra kattintva kijelzésre kerül a 
������
����� +�#�� � �	 �%�� ��
� )��
���
��%! Write  gombra kattintva az 
�������� � �	 /#�

�����
�����*  �� � ���%�� �� �%��� +�#�� 
Fill Range - � ���%	  
 � 
+�# ������� #�#���������#���� � �
(���89�+�%� #��	 ������#���� ����� ���! 
Auto Increment  - Kiválasztva minden Read és Write parancs után a 
+�# �

��� �	 /�����#������%��*!  
Close - A dialógusablak bezárása. 
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Help 
 
Az MPLAB Help menüje lényegében minden információt tartalmaz a programra vonatkozóan, külön szerepeltetve az 
����� �
��
 ��#�����
���! �� �
��
 
'
�� � ���� ���
���%�
� 
�
����%	 ��#����)
 #�%�� ������������� �
 ������
osztva. 
 

 
Az aktuális MPLAB verzióhoz kapcsolódó info. 
Az aktuális PICSTART verzióhoz kapcsolódó info. 
 

MPLAB program Súgója 
PICMASTER Emulátor Súgója 
-����������������!����	&�-.�)
	 
Picstart Plus programozó Súgója 
MPASM assembler program Súgója 
MPLABC C fordító program Súgója 
Az MPLAB-ról... 
 

Összefoglalás 
 

Foglaljuk össze azt, hogy hogyan kell használnunk az MPLAB-�� ���
��#����� �����
�� 
 ��! "�
	 � � 
� ��� �� # 

nincs projektünk a File->New Source#��.��������� � ���������)�� �
� '� �����
�����! ��
���  
 ����
���$��
 ����
megoldás az, hogy a létrehozott új projektünkbe egy átnevezett .ASM fájlt illesztünk, mert azt könnyen módosíthatjuk  a 
közös, szabványos részek meghagyásával. Ha szükséges. Akkor a projektbe INCLUDE fájlokat is beilleszthetünk. 
Ezek után a fájlokat a Projekt->Build All  menüpont segítségével lefordítjuk, az esetleges hibákat kijavítjuk. Ehhez az is 
segítséget nyújt, hogy a hibafájl megjelenítésekor rákattintva egérgombbal a kurzorral rámutatott hibás sorra, a 
�����
���
��# #�
�����	 
��� ������� #�
 � 
�����
��	���! 
A fálok futtatása a megfel��	 Debug #��.���� 
�
��
 
 ��� � 
�����	! ����������)�� ��� 
������� ���#����� 
��  


����
�� 
�� /
��#)�)
��* 
�
��
 
 ��� � �.�
	 ����������� �
 
��#)�������)�! � Watch ablak felhasználásával a futás 
során fontos regisztereket is figyelemmel kísérhetjük.���	��) & ��������
 �*�����"�� � ���������� 	%����	 �

�����������$�� ������		 	%���"�� ������ �+��� ��	����
 ������
) 
 
Egy ilyen összetett eszköz mint az MPLAB kezelése, használatának elsajátítása szorgalmas munkát igényel. A munkát 
������	
�� #�
������ti az eszköztárak és a státusz sor felhasználása. A leírás nem tért ki az egér használatára, de 
+ �
���$ mindkét �
 �
�#��� �.������	 
���)�+������ ����������� #��� 
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Négyféle eszközsáv van a munka könnyítésére: Projekt, Edit, Debug, User 

Ide kattintva tudunk az eszköztárak között 
váltani Ez a Státuszsor (Status Bar), 

tételeire duplán rákattintva 
azok módosíthatók  


