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1. Az Altium Designer 6 általános ismertetése 
 

Az Altium Designer 6 az Altium cég komplex, egységesített elektronikai 

gyártmányfejlesztő rendszere. A komplexitását mutatja, hogy a kapcsolási rajz tervezést, a 

nyomtatott áramkör tervezést, az FPGA tervezést, a kevert módú szimulációt, 

jelintegritás analizátort és a gyártásba vitelt támogató szoftver eszközöket is tartalmazza. 

Ezen felül lehetőséget nyújt – megfelelő hardver fejlesztőeszköz csatlakoztatása esetén – az 

FPGA működésének vizsgálatára és hibakeresésére (debugging). Az egységesítés azt jelenti, 

hogy a különféle elemek integráltan, egy felhasználói felületről (Altium Designer’s Design 

Explorer - DXP) érhetőek el, és az átmenet a fejlesztés különböző fázisaiban az egyik 

szoftvereszközből a másikba automatikusan, vagy egyetlen kattintásra megtörténik (nem 

szükséges köztes adatállomány létrehozása, vagy másik fejlesztőrendszer elindítása). Jelen 

leírásban – terjedelmi korlátok és a mérések szűkös időbeosztása miatt – csak a kapcsolási 

rajz és nyomtatott áramkör tervezésének lépéseit ismertetjük. Ez az ismertetés is csak 

részleges, a mérés elvégzését nagyban segíti a mérést támogató előadás meghallgatása. A 

fejlesztőrendszer további részleteivel önálló munka során, a beépített Tudásközpont 

(Knowledge Center, F1), illetve az Interneten található anyagok segítségével ismerkedhet 

meg. 
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A következőkben az Altium Designer kezelői felületét mutatjuk be. 

 

 

Rendszer menü 

Menük, 
eszköztárak Megnyitott 

dokumentumok

Menük, 
eszköztárak 

Menük, 
eszköztárak 

Fájl-navigáció 

Munkafelület 
paneljei

Munkafelület 
paneljei

Munkafelület paneljeinek 
gyors elérését segítő gombsor 

Fő tervezői 
munkaablak 1

3 

4
2

5

6 7

 

A felület hét fontos részre osztható: 

 

1. Fő tervezői ablak: itt látható a megnyitott dokumentumok közül az aktív, amelyet a 

típusától függően megtekinthetünk, vagy szerkeszthetjük. 

2. Megnyitott dokumentumok választó listája (fülek): a megnyitott dokumentumok 

választófülei, amelyekkel válthatjuk az aktív dokumentumot, illetve felette jobb 

gombbal kattintva beállíthatjuk a megjelenítési tulajdonságait. 

3. Rendszer menü: almenüpontjai segítségével a fejlesztői környezet megjelenését és 

alapértelmezett beállításait szabhatjuk át igényeink szerint, de itt tájékozódhatunk a 

felinstallált részprogramokról (szoftver szerverek) is. 

4. Menük, eszköztárak, gyorsparancsok: kisebb részben állandó, nagyobb részben az 

aktív dokumentumhoz igazodó szöveges és ikonos parancsok, menüpontok csoportja. 
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5. Fájl-navigációs mező: a megnyitott dokumentumok listáját tartalmazza, amelyhez 

hozzáadhatóak saját dokumentumok. A listából egy kattintással előre-hátra irányban 

gyors dokumentum-váltást tesz lehetővé. 

6. Munkafelület paneljei: az aktív dokumentum típusa szerint változó panelkészlet, 

amely gyorsabbá teszi a különféle műveletek elvégzését (pl. navigáció, alkotóelemek 

listája, jellemzők szerinti szűrés). 

7. Munkafelület paneljeinek gyors elérését biztosító gombsor: a panelek közötti gyors 

váltást segíti. 

 

Mivel az Altium Designer menürendszere igen összetett, ráadásul az aktív dokumentum 

típusától függően dinamikusan változik, ezért a részletes menüismertetéstől eltekintünk. 

A következőkben csak a fejlesztői környezet aktív dokumentum nélküli alap menüjéről 

adunk áttekintést. A menürendszer azon pontjait, amelyeket a példák során használunk, ott 

ismertetjük. 

 

File (Fájl) menü: 

 

• New: Itt hozhatunk létre új tervdokumentumot, könyvtárat, projektet vagy 

munkafelületet. (A projekt egy olyan dokumentumköteget jelent, amely egy-egy 

terv létrehozásához szükséges.) A létrehozható dokumentum-típusok között 

megtaláljuk a kapcsolási rajz (Schematic), nyomtatott áramkör (PCB) és különféle 

programfájl-típusokat (VHDL, Verilog, C, ASM). A következő könyvtárakat 

(Library) hozhatjuk létre: kapcsolási rajz elemek könyvtára (Schematic library), 

nyomtatott áramköri elemek (lenyomat, (Footprint)) könyvtára (PCB library), 

VHDL elemek gyűjteménye (VHDL library), nyomtatott áramköri 3D modellek 

könyvtára (PCB3D library), adatbázisok (Database library). A létrehozható 

projektek közül a fontosabbak: nyomtatott áramkör tervezési projekt (PCB Project), 

FPGA tervezési projekt (FPGA Project), funkcionális FPGA mag projekt (Core 

Project), integrált könyvtár (Integrated Library), beágyazott vezérlő szoftverének 

projektje (Embedded Project). A felsoroltakon kívül még számos fájltípus 

létrehozása történhet innen. 

• Open (Ctrl+O), Open Project, Open Design Workspace: a fenti típusok 

megnyitását végezhetjük el. 

• Close (Ctrl+F4): az aktív fájl bezárása. 
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• Save Projec, Save Project As, Save Design Workspac, Save Design Workspace As, 

Save All: a fenti típusok egyszerű, vagy más néven történő mentését végezhetjük el. 

• Smart Pdf: egy párbeszédablakos beállítás után olyan interaktív PDF fájlt 

hozhatunk létre, amelyben az objektumok elhelyezkedése könyvjelzőként el van 

tárolva, és így azok kereshetőek. 

• Import Wizard: a varázsló segítségével több más elektronikai tervezőprogram 

fájljait tudjuk átkonvertálni az Altium Designer formátumára. 

• Recent Documents, Recent Projects, Recent Workspaces: az adott csoporton belül a 

legutóbb megnyitott fájlok listája található, amely gyors elérést tesz lehetővé. 

• Exit (Alt+F4): kilépés a programból. 

 

View (Nézet) menü: 

 

• Toolbars: Megjeleníthetjük a fájl-navigációs (Navigation) eszközöket, és 

eltüntethetjük a dokumentum-kezelő ikonokat (No Document Tools), valamint 

testre szabhatjuk a beállításokat (Customize). 

• Workspace Panels: több kategóriára bontva – Design Compiler (Terv-értelmező), 

Help (Súgó), Instruments (Műszerek), System (Rendszer) – be- illetve 

kikapcsolhatjuk a munkafelületi paneleket. Ezek a panelek lebegő, vagy rögzített 

(dokkolt) állapotúra is állíthatóak. 

• Desktop Layouts:: a program által tartalmazott, vagy eltárolt munkaasztali 

elrendezéseket tölthetünk be, vagy az aktuális elrendezést eltárolhatjuk. 

• Devices View: megjeleníti az FPGA fejlesztéshez használt eszközöket. 

• Home: megnyitja az Altium Designer honlapját. 

• Status Bar: be- illetve kikapcsolja a program működési állapotát megjelenítő 

mezőt. 

• Command Status: be- illetve kikapcsolja a parancsállapot kijelzőt. 
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Project (Projekt) menü: 

 

• Compile: elindítja az Altium Designer elemző és fordító üzemmódját. 

• Show Differences: összehasonlít két fájlt, vagy két projektet, és megmutatja 

közöttük a különbségeket. 

• Add Existing To Project: létező dokumentumot adhatunk hozzá a projektünkhöz. A 

hozzáadott fájl a projektben a neki megfelelő kategóriába kerül (pl. 

forrásdokumentum, könyvtárdokumentum, generált fájl). Ha a kategória még nem 

létezik, az automatikusan létrehozásra kerül. 

• Remove from Project: a kijelölt dokumentumot eltávolítja a projektből. Ha a fájl 

utolsó volt a kategóriájában, az adott kategória törlődik. 

• Add Existing Project: a munkafelülethez létező projektet ad hozzá. (Egyszerre több 

projekt is lehet megnyitva.) 

• Add New Project: a munkafelülethez új projektet ad hozzá. 

• Project Documents (Ctrl+Alt+O): megnyit egy fájlkezelő ablakot, amelyben a 

projektet tartalmazó könyvtár, és a benne lévő dokumentumok láthatóak. 

• Version Control: az esetlegesen telepített verziókövető program szolgáltatásai 

érhetőek el ebből a menüből. (Ha nincs telepítve, hiányoznak az almenük.) 

• Archive: egy párbeszédablakot nyit meg, amelyen keresztül az aktív projekt 

archiválása végezhető el. Az archivált fájl tömörített formában tartalmazza a 

projekt forrásdokumentumait és egyéb fájljait. 

• Project Options: egy párbeszédablakon keresztül kategóriákba rendezett 

szempontok szerint elvégezhetjük a projekt beállításait. 

 

Window (Ablak) menü: 

 

A megnyitott Project Explorer ablakokat elrendezhetjük (Arrange) vízszintes vagy függőleges 

rendben (így nem fedik el egymást), illetve bezárhatjuk (Close) azokat. Bezáráskor 

dönthetünk a projekt és fájljai mentéséről. 
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Help (Súgó) menü: 

 

• Knowledge Center (F1): Megnyitja a Tudásközpontot, amely egy két fő mezőből 

álló ablak. Ennek felső része az egérmutató helyzetétől függően változó 

információt tartalmaz (pl. súgó az egérmutató alatti menüpontról). Az alsó része 

egy kereső, amely egyben meg is jeleníti a találatokat a súgó adatbázisából. (A 

Tudásközpont létrehozásában a „Learn As You Work” (munka közbeni tanulás) 

elvet követték a fejlesztőrendszer létrehozói.) 

• User Forums, Knowledge Base: Interneten elérhető, a tervezőrendszer használatát 

segítő anyagok (fórumok és kereshető tudásbázis), amelyek közvetlenül az Altium 

Designer ablakaiban kerülnek megjelenítésre. 

• Help On: különféle dokumentumok gyűjteménye, amely a kiválasztott téma 

használatát segíti. 

• Getting Started: különféle témákban egy-egy összefoglalót találhatunk PDF 

formátumban, amely az adott témában gyors munkakezdést tesz lehetővé. 

• About: névjegy, liszensz-információ és fejlesztőrendszerben felinstallált programok 

(szerverek) megjelenítése. 
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2. Mintafeladat megoldása: csúcs-egyenirányító tervezése 

 

Zárjunk be minden, esetleg megnyitott projektet (Project→Close Project, vagy a projekt 

panelen a projekt nevére mutatva jobb gombbal kattintunk, a felugró menüben: Close 

Project)! Hozzunk létre új projektet (File→New Project→PCB Project)! Az üres projekt 

„PCB_Project1.prjPCB” néven jön létre, ha addig ilyen néven más projekt nem volt. 

Mentsük el a projektet tetszőleges néven (File→Save Project As)! 

 

A projekt egyelőre nem tartalmaz forrásdokumentumokat, adjunk hozzá egy kapcsolási rajz 

(schematic) dokumentumot (Projects panelen jobb kattintás, majd a felugró menüben: Add 

New To Project→Schematic. A létrejövő üres dokumentum neve „Sheet1.SchDoc”, ha előtte 

nem volt ilyen nevű fájl. Mentsük el a kapcsolási rajzot tetszőleges néven (File→Save As). 

 

Ellenőrizzük, illetve igényeink szerint módosítsuk a rajzfelület beállításait! Ehhez a 

rajzfelület feletti jobb kattintás után megjelenő menüből válasszuk ki az Options→Document 

Options pontot! A lényegesebb beállítási lehetőségek: lapméret (Standard Style vagy Custom 

Style), lap tájolása (Landscape vagy Portrait), raszterháló (Snap Grid, Visible Grid) 

elektromos csatlakozópontok megengedett maximális eltérése (Electrical Grid). A beállítások 

után zárjuk be az ablakot! 

 

Rajzoljuk meg az alábbi kapcsolást! 
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Az egyes alkatrészek kiválasztása a könyvtárak (Libraries) paneljéről történhet. Ha a 

rajzfelület jobb szélén felül nem látszik a Libraries fül, akkor a View→Workspace 

Panels→System→Libraries útvonalon bekapcsolhatjuk azt. Ha a fül fölé visszük az 

egérmutatót, akkor megjelenik a teljes panel, amelynek felső részét az alábbi ábrán láthatjuk. 

 

 

Kiválasztott alkatrész 
elhelyezése 

Könyvtárkezelés 

Alkatrész keresése Könyvtárlista 

Alkatrész-szűrő 

Alkatrészlista 

 

A Libraries… gombra kattintva megnyílik egy párbeszédablak, amelyben könyvtárakat 

adhatunk hozzá a könyvtárlistához, illetve a könyvtárak sorrendjét megváltozathatjuk a 

listán belül. (A könyvtárakat az X:\Program Files\Altium Designer 6\Library\ helyen találjuk, 

ahol X az Altium Designer meghajtója.) A Search… gombbal név vagy névrészlet alapján 

kereshetünk ki egy adott alkatrészt, illetve az azt tartalmazó könyvtárat. A Place… gombbal 

a kijelölt alkatrészt helyezhetjük el a rajzfelületen. (Ezt a műveletet a listából a rajzfelületre 

való alkatrész-áthúzással is elvégezhetjük.) A könyvtárlista tartalmazza a felinstallált 

könyvtárakat, kiválaszthatjuk, hogy melyiknek a tartalma jelenjen meg a panel alján látható 

listában. Az alkatrész-szűrővel az alkatrészlistából csak a szűrési feltételnek megfelelő 

alkatrészek jelennek meg. 

 

Válasszuk ki a listából a szükséges alkatrészeket, és helyezzük el azokat! Ellenállás: Res2, 

kondenzátor: Cap, dióda: Diode 1N4148. Bár a listában találunk műveleti erősítőt (Op Amp), 

de mivel ez egy általános szimbólum, lábkiosztása nem felel meg a TL081 típusnak. 

Keressük meg a TL081 szimbólumát! Írjuk be a projekt panel Search… parancsának kiadása 

után felugró ablakban: „*TL081*”, keresési helyként pedig adjuk meg az „X:\Program 

Files\Altium Designer 6\Library\National Semiconductor” könyvtárat! (A TL081 egyik 
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gyártója a National Semiconductor. A keresési hely megadása lerövidíti a keresési időt, mivel 

leszűkítjük a vizsgálandó fájlok körét.) Miután a keresés lezárult, helyezzük el a rajzfelületen 

a TL081-et! Szükség lehet az alkatrészek forgatására. Ehhez az alkatrész felett lenyomva 

kell tartani a bal egérgombot, majd a SPACE billentyűvel lehet pozitív irányban 90°-ot 

forgatni az alkatrészen. (SHIFT+SPACE: negatív irány.) Ugyanez a forgatás megtehető még a 

listából kiválasztott, de el nem helyezett alkatrész esetében is. 

 

Végezzük el a huzalozást! Huzal lehelyezése a Place→Wire paranccsal lehetséges. Ha a 

huzalozásban töréspontot szeretnénk elhelyezni, egy kattintással tehetjük meg. A huzal akkor 

van az alkatrész egy kivezetésén, ha a kurzor alakja megváltozik: megjelenik egy piros „x”. 

Ezt mutatja az alábbi ábra. 

 

 
 

Az elhelyezés és a huzalozás után az alábbihoz hasonlóan néz ki a kapcsolásunk: 
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A következőkben változtassuk meg a kiindulási kapcsolási rajz szerint az alkatrészek 

pozíciószámát és értékét! A módosítani kívánt szövegen kettős kattintás után végezzük el a 

módosítást! Az alapértelmezésben megjelenő megjegyzések (pl. Res2) zavarják a rajz 

olvashatóságát. Ezek láthatatlanná tétele a kettős kattintás után megjelenő ablakban a Visible 

melletti négyzetből kivett pipa segítségével történhet. A szövegeket tetszőleges helyre 

húzhatjuk. (Másik, automatikus megoldás a pozíciószámok kiosztására az annotálás: 

Tools→Annotate….) 

 

Helyezzük el a tápcsatlakozások pontjait! A Power Port szimbólum a Place→Power Port 

paranccsal tehető le. Lehelyezés után átnevezhetjük, illetve megváltoztathatjuk az alakját. Itt a 

Vcc és a Vdd jelölésére nyilat, a földpont jelölésére a hagyományos föld jelölést alkalmazzuk. 

A Power Port szimbólumok jellemzői kettős kattintással állíthatóak be. (Amennyiben a 

későbbiekben szimulálni akarjuk az áramkört, akkor a tápcsatlakozások nevében nem 

szerepelhet feszültségérték, például Vcc helyett nem használhatjuk a +12V elnevezést!) 

 

A be- és a kimeneti csomópontokat nevezzük el! A csomópontok elnevezésére a Net Label 

szimbólum szolgál (Place→Net Label). A Net Label is hasonlóan viselkedik, mint egy 

alkatrész-szimbólum, itt is ügyeljünk a pontos elhelyezésre (kurzor megváltozik, megjelenik 

egy piros „x”). Kettős kattintás után beállíthatjuk a „Be” és „Ki” nevet. Rajzunk most az 

alábbihoz hasonlóan néz ki. 

 

 
 

12/20 



Áramkörtervezés Altium Designer 6 rendszerben I. BMF KVK MAI 

Innen két út áll előttünk. Vagy – ha szükséges – elvégezzük az áramkör szimulációját, vagy 

pedig ezt a lépést kihagyva, alkalmassá tesszük kapcsolási rajzunkat a nyomtatott áramkör 

tervezőbe való áttérésre. Példánkban elvégzünk egy egyszerű szimulációt, azután lépünk 

tovább. 

 

A szimulációhoz táp- és jelforrásokat kell elhelyezni a rajzon. A generátorokat a Utilities 

eszköztár Simulation Sources ( ) ikonja alól választhatunk. (Ha a Utilities eszköztár 

nincs bekapcsolva, bekapcsolhatjuk a View→Toolbars→Utilities parancs kiadásával.) Két 

+12V-os generátorból alakítsunk ki kettős táplálást, a +12V-ra helyezzünk el egy Vcc, a -

12V-ra pedig egy Vdd nevű tápcsatlakozást. A generátorok közös pontját kössük földre! A 

bemenetre helyezzünk el egy tetszőleges frekvenciájú szinuszos jelforrást! A jelgenerátor 

frekvenciáját állítsuk be 50Hz-re, amplitúdóját pedig 100mV-ra! A beállításokat a 

jelgenerátoron való kettős kattintás után felugró ablakban végezhetjük el. (Jobb alsó keretben 

VSIN modell kiválasztása, majd Edit. Model Sub-Kind: Sinusoidal, Parameters fül alatt: 

Amplitude: 1E-1V, Frequency: 50Hz. Mindkét megnyitott ablakot OK-val kell bezárni.) Ezek 

után a kapcsolásunk az alábbi ábrán látható. (A generátorok Comment mezőinek 

megjelenítését kikapcsoltuk, azonosítóinak (Designator) ésszerű, beszédes nevet adtunk.) 

 

 
 

Végezzük el az áramkör tranziens analízisét! Vizsgáljuk a bemenethez képest a kimenetet 

és a műveleti erősítő kimenetét! Indítsuk el a szimulációs üzemmódot 

(Design→Simulate→Mixed Sim)! A megjeleníteni kívánt jelek listájához (Active Signals) 

adjuk hozzá a Be, Ki és NetD1_1 csomóponti feszültségeket! (NetD1_1 – a műveleti erősítő 
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kimeneti pontja és D1 anódja által alkotott – csomópont neve az automatikus csomópont-

elnevezés miatt lehet, hogy más nevet kap.) A jelek hozzáadását többek között a baloldali 

listában (Available Signals) a jeleken való kettős kattintással végezhetjük. A szimulációs 

beállításokat az Analyses/Options lista Transient/Fourier Analysis sorának kijelölése után 

jobboldalon, a Transient/Fourier Analysis Setup ablakban végezhetjük el. Állítsuk be a 

megjeleníteni kívánt ciklusok számát (Default Cycles Displayed) 3-ra, az egy cikluson belül 

kiszámolt pontok számát (Default Points/Cycles) pedig 100-ra! Az OK gombra kattintva 

elindul a szimuláció. A szimuláció eredményét a megnyíló ablakban láthatjuk. 

 

Ahhoz, hogy könnyen össze tudjunk hasonlítani több jelet, egy grafikonon kell 

megjeleníteni azokat. A bemeneti jel mellett ábrázoljuk a kimeneti jelet! A bemeneti jelet 

tartalmazó grafikon felett jobb gombbal kattintva adjuk ki az Add Wave To Plot parancsot, 

és a felugró listából válasszuk ki a Ki jelet, majd fejezzük be a műveletsort a Create gombra 

való kattintással! A Ki csomópont feszültségének megjelenítése külön grafikonban ezek után 

szükségtelen, töröljük a grafikon feletti jobb kattintás után a Delete Plot paranccsal! Mérjük 

meg a kimeneti jel hullámosságát! A méréshez kurzorok használata szükséges. A Ki jelre 

kurzort a grafikon jobb felső sarkában a jel nevén való jobb gombos kattintással előugró 

menüből lehet elhelyezni (Cursor A, Cursor B). Mindkettőt kapcsoljuk be! Az A kurzort 

vigyük a bemeneti jel egyik csúcsértékének helyére (pl. 25ms-hoz), a B kurzort pedig állítsuk 

a kimeneti jelnek az időben következő legkisebb feszültségű pontjára! Ha baloldalt a 

panelek közül nem a Sim Data panel látható, aktiváljuk a megfelelő fülre kattintva. A 

szimuláció grafikus eredményeit és a szimulációs adatokat, valamint a program által 

kiszámított értékeket az alábbi ábrákon láthatjuk. A táblázatból kiolvasható, hogy a 

kimeneti jel hullámossága kb. 16,7mV. (A megjelenítéssel kapcsolatos egyéb beállításokat 

nem részletezzük, azokat menüből, vagy a szimulációs grafikonok feletti jobb kattintás után 

végezhetjük el.) 
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Tegyük alkalmassá kapcsolásunkat a nyomtatott áramkör tervezésére! Ehhez el kell 

helyeznünk a táp- és jelcsatlakozókat, valamint meg kell adnunk, hogy a nyomtatott 

áramkörön az egyes alkatrészeknek milyen lenyomat (footprint) feleljen meg. Módosítsuk az 

áramkörünket! Helyezzünk el egy hárompontos csatlakozót a tápfeszültség számára, és két 

darab kétpontosat a be- és a kimenetek számára! (A csatlakozókat megtaláljuk a 

Miscellaneous Connectors.IntLib könyvtárban Header 2 és Header 3 néven.) A 

szimulációhoz szükséges generátorokat természetesen törölni kell. Kapcsolási rajzunk a 

csatlakozók átnevezése és pozíciószámmal való ellátása után az alábbiak szerint alakul. (A 

forgatást – az előzőekben leírtakon kívül – valamint a tükrözést az alkatrészeken való kettős 

kattintás után előugró Component Properties ablakban tehetjük meg.) 

 

 
Most következhet az alkatrészlenyomatok kiválasztása. El kell dönteni, hogy SMD vagy 

hagyományos, esetleg kevert technológiájú panelt szeretnénk-e tervezni, és a lenyomatokat 

eszerint megadni. A programmal szállított alkatrészkönyvtárak általában tartalmaznak a 

kapcsolási rajz szimbólumokhoz rendelt lenyomatot is, ezek alapértelmezett értéke azonban 

nem mindig megfelelő. Példánkban a korábbi laboratóriumi foglalkozásokról jól ismert 

hagyományos (furatba ültethető) alkatrészekkel tervezzük meg az áramkörünket. Az 

alkatrészekhez a Component Properties – az alkatrészen végzett kettős kattintással előhívható 

– ablak jobb alsó részében (Models…) rendelhetünk lenyomatot. Az alkatrészhez rendelt 

alapértelmezett lenyomatot az Edit… gomb megnyomásával tekinthetjük meg, és ugyanitt 

módosíthatjuk is. Példaként nézzük meg, hogyan módosíthatjuk C1 alapértelmezetten RAD-

0.3 (három raszteres lábtávolságú) lenyomatát RAD-0.2 (két raszteres lábtávolságú) modellre! 

A Component Properties ablakban válasszuk ki a Footprint típusú modellt, és kattintsunk az 

Edit… parancsra! Másik lenyomatot a PCB Library mező Any (bármelyik könyvtár 

használata) beállítása mellett végezhetjük el. A Footprint Model mezőben kattintsunk a 
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Browse… gombra, majd a listából válasszuk ki a RAD-0.2 lenyomatot! Mindhárom 

megnyitott ablakból OK-val lépjünk ki! Ellenőrizzük az összes alkatrész beállításait! Ezzel 

kész a kapcsolási rajz a nyomtatott áramkör tervezőbe való átvitelre. 

 

Hozzunk létre a projektben egy üres nyomtatott áramköri dokumentumot (Project→Add 

New To Project→PCB)! Mentsük el a kapcsolási rajzzal azonos néven! (Tetszőleges néven 

elvégezhető a mentés, de célszerűen azonos névvel érdemes az összetartozó dokumentumokat 

elmenteni.) Ha a nyomtatott áramkör alakja és mérete előre eldöntött, akkor kezdhetjük a 

panel körvonalának megrajzolásával. Ha nem, akkor először elvégezhetjük a tervezést, és a 

végén jelöljük ki a nyomtatott áramkör körvonalát. Mi ez utóbbi szerint fogunk eljárni. 

 

A kapcsolási rajzot aktívvá téve adjuk ki a Design→Update PCB Document parancsot. 

Ennek hatására megnyílik az Engineering Change Order ablak, ahol tájékoztatást találunk a 

nyomtatott áramköri dokumentumon végrehajtani kívánt módosításokról. (Add 

Components - alkatrészek hozzáadása, Add Pins To Nets – csomópontok kialakítása, Add 

Component Class Memebers - alkatrészosztályok kialakítása, Add Rooms – 

alkatrészcsoportok helyének kialakítása). Kiadhatjuk az Execute Changes parancsot. Ha 

minden rendben van, akkor a Check és a Done oszlopban is csak zöld pipákat láthatunk. Ha 

valahol piros x jelenik meg, az hibát jelez, amiről üzenetet kapunk. Ha minden rendben van, 

zárjuk be Close paranccsal az ablakot! Automatikusan a nyomtatott áramköri dokumentum 

lesz aktív. 

 

Keressük meg a nyomtatott áramköri felületre betöltött objektumokat! (Jobb alsó sarok, 

a tervezési felületen kívül.) A lila színű kereten belül (de nem alkatrész felett) nyomva tartott 

egérgomb mellett húzzuk be az összes objektumot a tervezési terület közepére! (A lila 

keret egy úgynevezett Room Definition, amely az adott alkatrészcsoportba sorolt 

alkatrészeket tartalmazza.) Jelöljük ki a keretet, majd töröljük (Del), jelen példánál nincs 

jelentősége. A következő ábrán a tervezési felület egy részletén bemutatjuk a betöltött 

objektumokat. 
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Alkatrész-azonosító 

Csomópont neve 

Alkatrészláb (Pad) 

Logikai kötések (Net) 

Alkatrész 
körvonalrajza 

 

Amennyiben egymáshoz túl közel kerülnek az alkatrészek, vagy átfedés van közöttük, akkor a 

háttérben futó folyamatos ellenőrzés (online DRC, DRC: Design Rule Check) konfliktust 

jelez (Component Clearance violation). Ez a konfliktus egyfajta figyelmeztetés, okát meg kell 

szüntetni (hacsak nem szándékosan idéztük elő). A konfliktust világoszöld szín jelöl, 

ahogyan azt a következő ábra mutatja. 

 

 
Következő lépésként az alkatrészek elhelyezése történik. Az alkatrészek mozgatása a felettük 

nyomva tartott egérgomb mellett húzással történhet, forgatásuk pedig ugyanekkor a SPACE 

(vagy SHIFT+SPACE) billentyűvel. Igyekezzünk optimális elrendezést kialakítani (méret, 

kötések hossza)! Egy lehetséges elrendezést mutat az alábbi ábra. 
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Ezek után elkezdhetjük a huzalozást. Mivel hagyományos technológiájú alkatrészekről van 

szó, ezért célszerű a munkát az alsó rétegen (Bottom Layer) kezdeni, és ha ott nem 

tervezhető meg a nyomtatott áramkör, akkor áttérni a felső rétegre (Top Layer). Az alsó 

rétegen való tervezés aktiválásához a tervezési ablak alsó szélén található fülek közül 

kattintsunk a Bottom Layer nevűre! A huzalozás megvalósítását az interaktív tervezés 

(Interactive Routing) funkció használatával fogjuk bemutatni. Ezt az üzemmódot a 

Place→Interactive Routing paranccsal indíthatjuk el. Válaszuk ki az elsőként megtervezni 

kívánt kötést! Álljunk rá a kötés kezdőpontjára, majd kattintás után induljunk el a 

tervezéssel! Tervezés közben a TAB billentyűvel hívhatjuk elő azt az ablakot, amelyben az 

éppen tervezett kötés jellemzői (pl. vezetékvastagság – Trace Width, használt réteg – Layer, 

két réteg közti átvezetés tulajdonságai – Via Hole Size, Via Diameter) állíthatók. A 

vezetékben töréspontot kattintással tudunk elhelyezni. Érdemes először a tápvezetékeket 

megtervezni, azután az egymáshoz legközelebbi pontok összekötésétől, az egymástól egyre 

távolabbi pontok összekötése felé haladni. Az interaktív tervezési móddal kapcsolatos egyéb 

tudnivalókat (tippeket, trükköket) a mérést támogató előadáson ismertetjük. A logikus 

alkatrész-elrendezésnek és a kapcsolás egyszerűségének köszönhetően a nyomtatott áramkör 

egy rétegen megtervezhető. 

Végezetül a panel fizikai méreteit kell beállítani. Ehhez a Keep-out Layer-en a Place→Line 

parancs kiadása után „bekereteztük” az áramkört. Ügyeljünk arra, hogy a keret zárt legyen! 

Állítsuk be a viszonyítási pontot a panel bal alsó sarkára (Edit→Origin→Set, majd 

kattintás a keret bal alsó sarkán)! Válasszuk ki az összes elhelyezett objektumot az 

Edit→Select→All paranccsal! A Design→Board Shape→Define From Selected Objects 

paranccsal kialakíthatjuk a panel végleges formáját. (Nem kötelező lépés.) A megtervezett 

áramkör az alábbi ábrán látható. (Az alkatrész-azonosítókat a könnyű olvashatóságot 

figyelembe véve helyeztük el.) 

 

 

19/20 



Áramkörtervezés Altium Designer 6 rendszerben I. BMF KVK MAI 

Amennyiben gyártásba kell vinni egy megtervezett panelt, létre kell hozni a gyártáshoz 

szükséges fájlokat. Ezek közül a legfontosabbak: 

• alkatrészlista 

• Gerber fájlok (a gyártási filmeket előállító plotter számára) 

• fúrási adatokat tartalmazó fájlok (NC fúrógép számára). 

 

Az alkatrészlista elkészítése a Reports→Bill Of Materials paranccsal végezhető el. Kimeneti 

formátumként az alapértelmezett Excel formátumot érdemes meghagyni. Az előállított fájl 

tartalmazza a panel alkatrészeinek kiválasztott adatait. Ezekből az adatokból saját 

igényeinknek megfelelően összeszerkeszthető az alkatrészlista. Példaként közöljük a fenti 

panel átszerkesztett alkatrészlistáját. 

 
Típus/Érték Azonosító(k) Mennyiség Lenyomat Megjegyzés

TL081CP IC1 1 N08E DIP tok
1N4148 D1 1 DO-35
1u C1 1 RAD-0.2 2 raszteres
100k R1 1 AXIAL-0.4
Tap P1 1 HDR1X3
Bemenet P2 1 HDR1X2
Kimenet P3 1 HDR1X2

Közvetlen bekötés, 
alaktrész nincs 

beültetve  
 

A Gerber fájlok és az NC fúrófájl a File→Fabrications Output menüpont alatt érhetőek el 

(Gerber Files, NC Drill Files). A beállítások gyártótól függhetnek, de a legtöbb gyártó 

képes fogadni az alapértelmezett beállításokkal készült gyártófájlokat. A Gerber fájlok 

előállításánál egyetlen dolgot kell beállítani, mégpedig azt, hogy mely rétegekről készüljön 

nyomtatási fájl. Ezt a felugró Gerber Setup ablak Layers fülén tudjuk beállítani: a 

nyomtatandó rétegek neve mellé a Plot oszlopban pipát kell tenni. (Itt mindenképpen 

nyomtatandó az alsó réteg (Bottom Layer), esetleg a Bottom Solder Mask ha forrasztás-gátló 

lakkbevonatot is szeretnénk rá.) A furatfájlok generálása alapértelmezett beállítások mellett 

végezhető el. 
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