Fórum témák

» Több friss téma
Fórum » LED kijelzős voltmérő
 
Témaindító: Ferix_, idő: Márc 22, 2006
Lapozás: OK   21 / 21
(#) proli007 válasza kowi hozzászólására (») Feb 22, 2014 /
 
Hello! Ha megnézed a kínai adatlapon is +-5V van.. üdv!
(#) pinyó39 válasza kowi hozzászólására (») Feb 22, 2014 /
 
Sziasztok!
Elmegy az 5V-rol is csak pluszba kell még pár alkatrész.
(#) vladcepes hozzászólása Feb 27, 2014 /
 
Sziasztok! Most találtam meg ezt a topikot. Ezt szeretném ide berakni hátha esetleg valakinek van ötlete Bővebben: Link És még egyszer elnézést hogy nem találtam meg hamarabb.
Válaszokat előre is köszönöm!
(#) ktamas66 válasza vladcepes hozzászólására (») Feb 28, 2014 /
 
Mivel csak hex-ed van abba nem tudsz belenyúlni, de PIC nélkül leellenőrizheted a kijelzők működését. Kiveszed a PIC-et és ahova 0-át adsz az a szegmens világít. Digit kiválasztás: 0 kell adni a megfelelő digitre (11-12-13 láb). Így végigellenőrizheted a helyes bekötést.
(#) vladcepes válasza ktamas66 hozzászólására (») Feb 28, 2014 /
 
Szia! Okés,köszönöm. Kiveszem a Pic-et és 0-át adok. De mi az hogy 0-át adok? Bocs a láma kérdésért.
(#) ktamas66 válasza vladcepes hozzászólására (») Feb 28, 2014 /
 
Földre kötöd .
(#) vladcepes válasza ktamas66 hozzászólására (») Feb 28, 2014 /
 
Köszönöm, holnap ki is próbálom,majd írom mi történt.
(#) vladcepes válasza ktamas66 hozzászólására (») Feb 28, 2014 /
 
Na reggel megnéztem,kivettem a Pic-et és:
11 lábnál nem világít,
12 lábnál nem világít,
13 lábnál a digitnek a pontja világít. (más semmi).

Egyébként a Pic-el is amikor a középső meg a jobboldali digit világít akkor a középsőnél a pont is világít.
Mikor kötöttem be a kijelzőket megnéztem az adatlapját és a szerint kötöttem.
(#) Csupasz válasza vladcepes hozzászólására (») Feb 28, 2014 /
 
Az viszont csak úgy lehet, ha elnézted a bekötést....
(#) vladcepes válasza Csupasz hozzászólására (») Feb 28, 2014 /
 
Na majd akkor kezdem elölről.
A bekötése gondolom így történik. 1 kép.
A lényeg gondolom hogy az A,B,C,D,E,F,G lábak mindháromnál legyenek összekötve,majd ezek mennek a Pic megfelelő lábaira.
A 3-8 lábat össze kell kötni és megy le GND-re?
A DP az csak a középső szegmensből megy a PIC 13-lábra? a másik két szegmens Dp-je marad üresen ?

A 2-es képet amit berajzoltam pirossal a nyákon a két tranzisztor(T1-T2) nem fordítva van bekötve?
Na majd este nekiugrok még egyszer.

UI: Lehet hogy a 3-8 as lábakat mindháromnál összekötöttem de nem vittem le földre. Nincs előttem a ketyere ez csak rémlik.
(#) Csupasz válasza vladcepes hozzászólására (») Feb 28, 2014 /
 
Szia
A bekötést Te látod az adatlapon.A hármast és a nyolcast nem kell összekötni, vagy egyiket, vagy másikat kötöd be.Mivel a kijelzés 1 tized pontosságú, így a többi dp-t sem kell bekötnöd, csak azt az egyet, a többi marad üresen.
A tranyák bekötését így látatlanba nem tudom megmondani.
(#) vladcepes válasza Csupasz hozzászólására (») Feb 28, 2014 /
 
Szia! Okés! a 3-ast vagy 8-ast,azt akkor nem GND-re kötöm rajz alapján hanem a Tranzisztor C-ra ugye? Csak mert a Lábkiosztásnál írja a 3-8 as GND a rajzon a Tr. C-re megy rá.
(#) proli007 válasza vladcepes hozzászólására (») Feb 28, 2014 /
 
Hello!
- Itt némi kuszaság van. Ha a 3-8-at a GND-re kellene kötni, akkor a kijelző közös katódos lenne. A rajzhoz meg közös anódos kijelző való. Hiszen a tanyó, a közös lábat a +5V-ra húzza fel.
- Ellenőrizni a kapcsolást meg úgy kellene, hogy az IC-t kiemelve, a 11-es lábat a GND-re húzva, sorba GND-t kellene adni a 10-7-5-6-8-9-2-es lábaknak. Ekkor sorba világítanak a szegmensek. Majd a 13-as lábat a GND-re, és újból végig tapogatni mint előbb. Így minden digit és minden szegmens kipróbálható. Ha így működik, akkor jöhet a PIC.
(Nem ártana meg is érteni valaminek a működését, ha valamit készítesz. Mert úgy látom ez nálad még nem törekvés egyenlőre. Pedig így egyre csak a problémákba fogsz bonyolódni..) üdv!
(#) ktamas66 válasza vladcepes hozzászólására (») Feb 28, 2014 /
 
A kijelző egyik lábát sem kell GND-re kötni. Előtte kimérheted a kijelzőt, digitmultival a pirosat a 3 vagy 8 lábra, a fekete a szegmensekre, halványan világítani szokott, ha csak fordítva világít, nem megfelelő típusú a kijelződ.
(#) vladcepes válasza proli007 hozzászólására (») Feb 28, 2014 /
 
Szia!
Közös anódost vettem.Már belebonyolódtam a fentebb belinkelt 1 kép alapján. (egyébként az este is mikor összeraktam nem kötöttem egyiket sem Gnd-re).
Le ellenőrzöm a kapcsolást ahogy leírtad.
Törekedni törekedek a megértésén, ha valamit is próbálok azért is kérdezek mert nem akarok hülyeséget csinálni.
Köszönöm!
Üdv!
(#) vladcepes hozzászólása Feb 28, 2014 /
 
Sziasztok! Szétkaptam az egészet,ùjbòl megcsináltam, most mindegyik világít de a kijelzőn nem 00.0 van hanem 2.58, a trimmert ha tekerem felmegy 30.0 ra. Ez mitől lehet? Vagyis nem. 00.0 van a kijelzőn.
(#) vladcepes válasza proli007 hozzászólására (») Márc 1, 2014 /
 
Megcsináltam sikerült
Már csak a trimmert kell lecserélnem egy nagyobb helitrimmerre a pontosabb beállításra.
A 10 K trimmer feltekerve teljesen nem mutatott annyit ha valamit mértem mint a multi.
Aztán beraktam egy 50K trimmert azzal sikerült csak sokat kellett vacakolni amíg eltalálta.
Üdv!
(#) vladcepes hozzászólása Márc 1, 2014 /
 
Van ennek egyébként valami más beállítási lehetősége? Mert lemértem pl:egy 6V-os akkut multival aztán beállítottam ezt hozzá a trimmerrel, majd amikor mértem vele egy 12V akkut,vagy más adaptert, egy 12V-ost ,egy 17V-ost akkor ilyen 1,5V ; 2V-os eltérés volt a Multihoz képest.
Ez ilyen,ennyit tud? A kapcsolási rajzon nincs,de a szerző a nyákrajzon berakott egy C3 kondit a tápfeszültségnél. Ez milyen értékűnek kéne lenni? 100µF ?
(#) proli007 válasza vladcepes hozzászólására (») Márc 1, 2014 /
 
Hello!
- Kalibrálni valahogy nem igazán így kell valamit. Inkább a méréstartomány végén kellene beállítani, nem akárhol. Közvetlen az IC bemenetén kellett volna feszültséget mérni, és megállapítani, a végértékhez ott mekkora feszültség szükséges. És az osztót ez alapján számítani. A beállító potinak meg nem ekkora átfogást kell használni. Csak annyit, amivel az ellenállások tőrésének kétszerese.
- A bemeneten az az 5,1V-os zéner, nagyon nem jó. Így nem lehet egy bementet védeni. Mert a zéner nem 5,1V-on nyit ki, hanem sokkal kisebb értéken, és eltorzítja a karakterisztikát. Avagy mint látható is linearitás hibát okoz. Kezdetnek vedd ki a zénert, és mérj úgy.
- Mivel a méréshatár 30 és ekkor az AD bemenetén 5V kell, a két ellenállás aránya 5:1. Ha a felső tag 47k, akkor az alsónak 9,4k-nak kell lenni. Vagy is célszerű az alsó tagként 9,1k és 1k trimmert használni. Ekkor a bementi feszültség osztását 28,3..30,8V között lehet állítani. (Amennyiben az ellenállások és az 5V pontos.)
- Kondi mindenképpen kell a tápra, de egy 100nF is közvetlen a PIC közelébe.
- A szimulációban látható mi történik. Az első, amikor egy nagy teljesítményű zéner van alkalmazva. A másodikon mikor kis teljesítményű. A harmadikon, mikor a zéner elő van feszítve az 5V tápfeszültségből és a védelmet diódák látják el. Nos, ott már valóban 5V van a VM3 műszeren. A határolás, meg maximum 5,2V. (Fordított polaritással, meg -600mV lenen.)
üdv!
A hozzászólás módosítva: Márc 1, 2014
(#) vladcepes válasza proli007 hozzászólására (») Márc 2, 2014 /
 
Szia!

Kiveszem a zénert és mérek úgy. Aztán követem majd amit feljebb írtál.
220µF kondi volt betéve és a a Pic Vss-Vdd lábra egy 100nF kondi.
Az 5V az pontos.
Köszönöm!
Üdv!
(#) vladcepes válasza proli007 hozzászólására (») Márc 23, 2014 /
 
Hello!
Kiszedtem a zénert,meg a trimert kicseréltem egy heli trimerre most az eltérés
0,1-0,4V .
Üdv!
(#) proli007 válasza vladcepes hozzászólására (») Márc 23, 2014 /
 
Hello! Oké. számold át ezt a hibát a műszer végértékéhez képest ez hány százalék. És akkor megtudod hogy ez számodra megfelelő-e. üdv!
(#) vladcepes válasza proli007 hozzászólására (») Márc 24, 2014 /
 
Hello! Szerintem tökéletes. Üdv!
Köszi a segítséget.
Következő: »»   21 / 21
Bejelentkezés

Belépés

Hirdetés
Frissek
2014. Júl, 22. Kedd
21:31:29
Jelenleg 597 fő olvassa az oldalt
Online tagok:
Lapoda.hu     XDT.hu     HEStore.hu