Fórum témák

» Több friss téma
Fórum » GPS GSM modulok programozása
Lapozás: OK   26 / 26
(#) Tardief hozzászólása Júl 5, 2020 /
 
Sziasztok!

Egy MC60 modullal próbálkozok éppen. A képen több, mint három óra mérése eredménye látható. A mérés során az antennát nem mozdítottam el, ennek ellenére a mérések elmásznak. Érdekes, hogy K-Ny irányban nagyon kicsi a hiba, de É-D irányban folyamatos a mászkálás. (Ennek oka lehet, hogy az antenna az ablakpárkányon van, ahonnan csak a fél égbolt látszódik tisztán)
Ettől nagyobb pontosságban reménykedtem a használt aktív antennával.
A mászkálásra van valami megoldás? A végső eszköz autóba lesz.

MC60.jpg
    
(#) proba válasza tufatofu hozzászólására (») Júl 5, 2020 /
 
A soros illesztő TX lábra feszültségosztót tesznek. Az RX lábra egy soros ellenállást. Arduinóval való összekapcsolásnál a korrektebb helyeken nem hagyják le, onnét lophatsz mintákat.
(#) Bakman válasza Tardief hozzászólására (») Júl 5, 2020 / 1
 
Akkor nem mászkál, ha mozog, egyébként mindegyik ilyen, lásd melléklet, u-blox NEO-6. Térkép: Győr, Tesco parkoló. Mozgás közben max. 30 km/h és némi parkolás.
(#) Tardief válasza Bakman hozzászólására (») Júl 5, 2020 /
 
Érdekes. Ilyen pontosság már bőven jó lenne.
Elviszem majd egy körre és kiderül.
(#) Bakman válasza Tardief hozzászólására (») Júl 5, 2020 /
 
A "Pontosság..." nevű képek egy helyben állva értendőek.
(#) superuser válasza Tardief hozzászólására (») Júl 6, 2020 /
 
Gyári EVB? Impedancia illesztett RF nyomvonal?
Ha nem, akkor az utóbbi szerintem beleszólhat a jel minőségébe.
(#) Tardief válasza superuser hozzászólására (») Júl 7, 2020 /
 
Saját NYÁK. Az adatlap nem tartalmazott túl sok okosságot a NYÁK-ra vonatkozóan, ezért nem is igazán törődtem vele. A második verzióra megpróbálok utána nézni a dolognak.
(#) Tardief hozzászólása Aug 20, 2020 /
 
Sziasztok!

Újabb problémába ütköztem a Quectel MC60 modulom használata során.

MQTT üzeneteket szeretnék küldeni egy Raspberry-n futó mqtt brokernek, de nem tudok csatlakozni.


+QMTOPEN=0,"213.222.148.142",1883
Elméletileg ezzel a paranccsal kellene működnie de válaszkénet ezt kapom az első alkalom után:
+QMTOPEN: 0,3 (A 3-as jelentése: Failed to activate PDP)
A második alkalomtól kezdve pedig ezt:
+QMTOPEN: 0,-1 (Az 1-es jelentése: Failed to open network)

Nem értem, hogy mi lehet a gondja.
Sajnos interneten nem sok hasonló esetet találtam.

Találkozott már valaki hasonlóval?
A hozzászólás módosítva: Aug 20, 2020
(#) superuser válasza Tardief hozzászólására (») Aug 21, 2020 /
 
At+cgatt? Paranccsal ellenôrizd a szolgáltatás meglétét.
Amúgy vegyél elô egy application note-ot és kövesd lépésrôl lépésre a példa szekvenciát. Quectel dokumentációk jók.
(#) superuser válasza Tardief hozzászólására (») Aug 21, 2020 /
 
Megnéztem egy AN-t és összetettebb kérdés, mint ahogy az előző hozzászólásban írtam.
Mindenképpen javaslom, hogy vegyél elő egy AN-t, olvasd át hogyan működik ez a funkció, hogyan kell felkonfigurálni és megnyitni egy kapcsolatot.
Alapvető kérdés, hogy SSL-el alapú, vagy SSL nélküli kapcsolatot akarsz indítani. Ehhez tudnod kell persze, hogy szerver oldalon mi fut.

Ez a BG96-hoz van, nem tudom az MC60 ugyanezzel a parancskészlettel dolgozik-e.
Regisztrál Quectelhez és tölts le egy ahhoz valót, nehogy emiatt ne működjön.
BG96 MQTT App.Note
(#) Tardief válasza superuser hozzászólására (») Aug 22, 2020 /
 
Köszönöm a segítséget.
Érdekes módon most működik, pedig nem változtattam semmit. Ez nem feltétlen a legjobb hír, mivel megbízhatóan kellene működni.
(#) phr3ak hozzászólása Dec 1, 2020 /
 
XM1110 modulhoz keresek firmware-t. A kiolvasás az NMEA interface-en keresztül lehetséges, ha valakinek lenne ilyen modulja... Köszi.
(#) superuser válasza phr3ak hozzászólására (») Dec 1, 2020 /
 
Miért akarsz rajta firmware-t cserélni?
(#) mateatek hozzászólása Jún 23, 2021 /
 
Üdvözlet!

Azt szeretném kérdezni, hogy egy SIM800-as modul használata esetén milyen AT parancsot kell küldeni, hogy híváskor a hívószám kijelzés aktív legyen?

Köszi!
(#) bbb válasza mateatek hozzászólására (») Jún 23, 2021 / 1
 
Na erre nem tudom a választ, de a *31#telefonszám jelzi a központnak, hogy küldje a számod, a #31#telefonszám pedig úgy indítja a hívást, hogy ne küldje. Ez régi trükk már, de tudomásom szerint még működik
(#) Tomi20 válasza mateatek hozzászólására (») Jún 23, 2021 / 1
 
Szia

Ha nem kapnál mástól jobb ötletet, megpróbálhatod, hogy a hívószám elé beírod a *31# előtagot, így szolgáltatói beállítástól függetlenül elküldi a számot (T-mobil hálózaton biztos működik). Én mobiltelefonnál így tudtam megoldani.
(#) mateatek hozzászólása Jún 24, 2021 /
 
Köszönöm mindkettőtöknek, ez így működik is. Sajnos, hiába teszem be a SIM kártyát egy telefonba és állítom be rajta a hívószám küldését. Ha kiveszem a SIM kártyát a telefonból, visszaáll alap helyzetbe.
(#) user1914 válasza mateatek hozzászólására (») Jún 24, 2021 /
 
Hi!
Nem a telefonon kellene beállítani, hanem a központban kellene az alapbeállítást módosítani.
A T-nél az ügyfélszolgálat segít mit kell elküldeni SMS-ben.
"díjmentes SMS-el, a +SZAMKIJELZES hívószót elküldve a 1414-es számra".
Vagy az ingyenes telefonszámon magad megteheted.
"a 1414-es telefonszámunkon".
A készülékedről magad megcsinálhatod, az egész leírás itt található LINK.
Üdv. M.
(#) proba válasza mateatek hozzászólására (») Jún 24, 2021 /
 
AT+CLIP=1 . De lehet, hogy ez csak a helyi kiíratás.
Elég bootoláskor egyszer beküldeni.
A hozzászólás módosítva: Jún 24, 2021
(#) Gafly válasza bbb hozzászólására (») Jún 24, 2021 /
 
(#) forrotamas hozzászólása Júl 19, 2021 /
 
Sziasztok,

Egy olyan észrevételem van SIM900 modullal (+Arduino Uno) kapcsolatban, hogy elindul a rendszer, veszi és küldi az sms-eket, majd az éjszaka folyamán elengedi a hálózatot, másnap már csak úgy lehet életre kelteni, ha újraindítom, viszont akkor ismét észhez tér. A SIM kártya Vodafon feltöltőkártyás.

Van esetleg valakinek ötlete, miért csinálhatja ezt?
Előre is köszi!
(#) jefflynn válasza forrotamas hozzászólására (») Júl 19, 2021 / 1
 
Nagyon sok Simcom modulos készüléket adtam el, nem voltak ilyen problémáim. Táp gond esetleg? De nem ez a fontos, hanem az, hogy szoftverből le kéne kezelned ezt az esetet, és újraindítani a modult.
(#) forrotamas válasza jefflynn hozzászólására (») Júl 20, 2021 /
 
Köszönöm a válaszod, én is egy szoftveres reset-en gondolkoztam. Táp ipari 5V 3A, az olvasataim szerint elégnek kellene lennie (sikeresen csatlakozik a szolgáltató hálózatához). Köszi még egyszer!
(#) superuser válasza forrotamas hozzászólására (») Hé, 7:17 / 1
 
Egyik alapvetô probléma az Arduino rendszereknél, hogy mások kódját használja fel mindenki, annak ismerete és megértése nélkül. Letöltesz valahonnan egy "SIM900_gsm_modul_drivert" aztán keresed a hibát.
Persze szólj ha nem ez történt, ezt általánosságban írtam.
A konkrét esetrôl:
Ellenôrizd, hogy nem kapcsolt-e ki a modul /status pin level/
Ellenôrizd, hogy hálózaton van-e a modul /ráhívás/
Az, hogy a táp tudja a 3A-t, az egy dolog, a layout egy másik.Ha nnem rövid izmos vezetôn megy a táp a gsm-hez, vagy nincsen közvetlen mellette a szükséges low esr kapacitás, akkor fújhatod.
Amúgy meg biggyessz rá az uart-jára egy kábelt és egy terminált, logold a kétirányú adatforgalmat, ezekkel megint elôrébb vagy.
(#) Gafly válasza superuser hozzászólására (») Hé, 7:43 /
 
Ebben neked tökéletesen igazad van.
Abban is, hogy csak letöltenek minden vacakot, amit a neten találnak, aztán megy a "nyivákolás". Az ingyen szoftvernek is ára van...
Abban is, hogy a nem a chipset-nek ajánlott topológiát használják, terveznek "jobbat". Méghogy 3 Amper, hülyék ezek, höhöhö...
Én is általánosságban irtam.
A hozzászólás módosítva: Hé, 7:44
Következő: »»   26 / 26
Bejelentkezés

Belépés

Hirdetés
Lapoda.hu     XDT.hu     HEStore.hu
Az oldalon sütiket használunk a helyes működéshez. Bővebb információt az adatvédelmi szabályzatban olvashatsz. Megértettem