Fórum témák

» Több friss téma
Fórum » Jelgenerátor - függvénygenerátor
Lapozás: OK   5 / 8
(#) pont válasza devergo74 hozzászólására (») Márc 2, 2016 /
 
Fülhallgató kimenet?
(#) szikorapéter hozzászólása Aug 20, 2016 /
 
Sziasztok. Van itthon egy 566-os típusú VCO-m és ebből szeretnék egy egyszerű generátort építeni. Viszont ott akadtam meg hogy csak 2,2k -s helio potmétert találtam itthon,a kapcsolás viszont mindenhol 10K-s potmétert ír elő. Esetleg valaki ismeri ezt az ic-t?
(#) szikorapéter válasza szikorapéter hozzászólására (») Aug 20, 2016 /
 
Bocsánat 2,5K-s a helio potméter.
(#) proli007 válasza szikorapéter hozzászólására (») Aug 20, 2016 /
 
Hello! Nem ismerem, de az adatlapon látható, hogy a vezérlő bement egy tranzisztoros áramgenerátor. Ezt vagy a bázis feszültséggel, vagy az emitter ellenállással lehet vezérelni.
Tehát alapvetően a frekvencia vezérlésnek két módja "szokásos".
Vagy fix feszültséget adnak a bázisra egy feszültségosztón keresztül és változtatják az emitter ellenállás értékét, ekkor számít a poti ellenállása.
Vagy fix emitter ellenállást használnak és a bázis feszültség értékét változtatják. Ekkor nyilván nem kritikus a poti értéke, mert feszültséget szabályoz a poti.
Minden esetre van korlátja a feszültség vezérlésnek, de ez látható az első képen. Mert én úgy látom, hogy a bázis feszültség nem vehet fel bármekkora értéket a két táp között.
A másik képen egy műveleti erősítővel van "feljavítva" a vezérlés. Ekkor tulajdonképpen nem a belső tranyó feszültségei számítanak, hanem az OPA beállítja a potival arányos feszültséget az emitter ellenálláson. Ez sokkal jobb eredményt ad, mert "eltűnik" a tranyó bázis-emitter nyitófeszültsége és görbéje. Viszont az áramkörhöz kettős tápfeszültség kell, és az 566 kimenti jele a GND és a negatív táp között fog megjelenni. (A módszer jó, de én nem így oldottam volna meg áramkörileg.)
Minden estre az "kiolvasható" a kapcsolásból, hogy az áramgenerátor maximális árama 1mA körül van. Az adatlap nem túl bőbeszédű a vezérléssel kapcsolatban (vagy nem vagyok elég figyelmes), mindössze az emitter ellenállás értékét (R1) 2..20kohm-ban határolja. A5-ös feszültség vezérlés lábát pedig így határozza meg: "2. The bias voltage (VC) applied to the control terminal (Pin 5) should be in the range V+≤VC≤V+." Nos ezt a relációt én nem tudom értelmezni..
Tájékozódni a frekvenciát meghatározó képletből, és frekvencia/kapacitás grafikonból lehet. Ott 12V tápfeszültség és 10V vezérlő feszültség (ahol ténylegesen az 2V, mert a vezérlő feszültséget a (V+)-Vc különbsége adja) mellet ábrázolja a kondi és a (maximális) frekvencia összefüggését. A kapacitás értéke viszont el van írva, mert az nem Farad-ra, hanem µF-ra vonatkozik. (Elég slampos a dolog.)
(#) szikorapéter válasza proli007 hozzászólására (») Aug 20, 2016 /
 
Most a második kapcsolás megfogott. LM324-el megfelelne-e vajon ha megépítem. Marad ugyanúgy a 2,5K-s helio, berakom a 100K-s potméter helyére,és alul tudom a máik potival korrigálni. Az első képen lévő kapcsolást már építettem meg vele,lényegéven a kondenzátor értéke is nagyon sokat befolyásol ( 5 különböző értéket raktam a kapcsolásba, egy forgó kapcsolóval váltva köztük.) A második kapcsolás megtetszett,viszont most még egy utólagos "erősítő" beépítésén gondolkozom ,ami képes ezen a tartományon,ezeket a jeleket rendesen erősíteni,mondjuk 15V csúcstól csúcsig tartó feszültség értékre. Gondolom erre egy egyszerűbb tranzisztoros erősítő is megfelel BD13x-es tranzisztorokkal.
(#) proli007 válasza szikorapéter hozzászólására (») Aug 20, 2016 /
 
Nyugodtan megépítheted a 324-el, működni fog, mert kettős tápfeszültséggel működik az OPA.
Hogy milyen erősítőt építs hozzá, ahhoz kérd ki azok tanácsát, akik itt a topikban már készítettek generátort. De egy 1MHz-es háromszögjelet, pld. már nem oly egyszerű alakhűen felerősíteni. És ne feledd, a DC szintet is helyre kell állítani (nullára) a generátor kimenetén.
(#) szikorapéter válasza proli007 hozzászólására (») Aug 20, 2016 /
 
A DC szint helyreállítását már akár a 324-ben lévő műveletivel is elkövethetem igaz? Vagy nem bír akkora frekvenciát alakhűen átadni? Az erősítőre meg egyenlőre próbálok valamilyen kapcsolást nézni,amit aztán felteszek ide.
(#) proli007 válasza szikorapéter hozzászólására (») Aug 20, 2016 /
 
A 324 nem egy bajnok, legfeljebb 20kHz-ig használhatod..
(#) rascal válasza szucsistvan123 hozzászólására (») Okt 7, 2016 / 1
 
Igen, van. Még aktuális?
(#) szucsistvan123 válasza rascal hozzászólására (») Okt 7, 2016 /
 
Szia!
Már megoldódott! Azért köszi!
(De elküldheted, ha gondolod, mert érdekelne! )
(#) elektroncso hozzászólása Márc 20, 2018 /
 
Sziasztok.
Egy őrjítő problémába akadtam. Idén az OEKV-re egy alacsony frekvenciás jelgenerátort építek. Szeptember óta építgetem ahogy időm engedi az érettségi mellett, tök jól álltam vele egészen a mai napig. A tavaszi szünet előtt elkészültem az alfa verzióval, ami az elvártaknak megfelelően üzemelt. Letisztáztam kapcsolási rajzot és megterveztem a végleges panelt (jelenleg béta verzió). Még a panel legyártására is volt időm a tavaszi szünet előtt. A szünetben beültetem amit tudtam (nem felejtettem a suliban) majd tegnap bekábeleztem, és felélesztettem a béta verziót. Először nagyon örültem, működött vagyis nem rontottam el a panelt. Én kis naiv azt gondoltam, hogy elkezdhetem a végleges panelt legyártani miután ezen a béta verzión kipróbálok minden beállítást és üzemállapotot. Itt jutottam el egy fura jelenséghez ami ma már az őrületbe kergetett. Ennek a megoldásában kérném a segítségeteket, egész nap ezen dolgoztam, de nem jutottam sokra.
A műszer alapja egy szinusz jelet előállító wien-hidas generátor (a műszer ezen kívül tud még négyszög és háromszögjelet is de azokat a szinuszból formálja). A wien oszcillátort három dekádban lehet 100Hz-100kHz között hangolni, a dekádon belüli folyamatos hangolásról két darab egy fogaskerék áttétellel közös tengelyre hozott helikális 10 fordulatú poti gondoskodik. Mint mondtam a generátor tökéletesen működött az alfa verzióban itt viszont 35kHz fölé hangolva felborul az amplitúdó stabilizálás és járulékos amplitúdó moduláció keletkezik, majdnem 100%-os modulációs mélységgel. A mellékletben láthassátok az oszcilloszkóp ábrát (illetve mégsem láthatjátok, most nézem, hogy valamiért nem tudja a gép olvasni őket, csináltam helyette egy ronda rajzot amit láthassátok, hogy kb mit láttam szkópon). Az értelmezése a következő: A két piros vonal az időmérő marker, a világoszöld terület tökéletes 70kHz-es szinuszjel (ez a számomra szükséges frekvencia), a sötétzöld pedig a burkológörbéje az AM-nak. A hullámvölgyekben a jel kb. 10%-ára esik a normál értéknek, a hullámhegyeken torzul, mert "beveri a fejét" a tápfeszültségbe. A három sáv közül csak a 10kHz-100kHz sávon jelentkezik a hiba és csak ha fölé hangolom 35kHz-nek. De mint mondtam a generált szinuszjel tökéletes, csak amplitúdóban ingadozik. Én már mindent kipróbáltam ami eszembe jutott, de nem jutottam előbbre. Mellékelem a paneltervet (citromsárgával bekarikázva az érintett panelrészt), az eredeti kapcsolási rajzot ami az RT17/02 számában jelet meg és az általam véglegesnek ítélt rajzot amiben csak pár apró módosítás történt. Kérlek nézzétek át tik is, mert én már rengetegszer átnéztem, de nem akadtam hibára, lehet átsiklok felette. Egyáltalán mi okozhatja ezt a járulékos AM-et? En arra gondoltam, hogy valamiért az IC102 által felépített szabályozókör gerjed be, de a kimenetén jele sincs gerjedésnek. A negatív visszacsatolásba fényellenállás van beépítve, de ha azon keresztül jutna be moduláció akkor annak 50Hz-esnek kéne lennie (fénycsővilágítás van a műhelyben), ráadásul a LED és a fényellenállás egy zárt alu tokban van (kibelezett elkó háza).
Előre is köszönöm a segítséget!
A hozzászólás módosítva: Márc 20, 2018
(#) proba válasza elektroncso hozzászólására (») Márc 20, 2018 /
 
Abba is belefuthattál, áthallásos lett. Valahol két alkatrész/fólia túl közel került egymáshoz. Valaha erősítő bemeneten figyeltem meg, két kondenzátor egymástól 0.5-1 cm-re volt egymástól és ha már lehet párhuzamosan. Már hangfrekvencián is jelentős áthallást okozott. Azóta értem miért tesznek két párhuzamosan futó jel ág közé egy föld csíkot.
(#) sany válasza elektroncso hozzászólására (») Márc 20, 2018 /
 
Nem lehet, hogy a végfokban található tranzisztorok nem teljesen egyforma paraméterekkel rendelkeznek? Tudom, hogy komplementerek, de hátha... Csak egy ötlet.
(#) elektroncso válasza proba hozzászólására (») Márc 20, 2018 /
 
Ez logikus lenne, ha volna a panelen valami ami 185Hz-es jelet generálna, de nincs. Megpróbáltam már azt is, hogy 10μF-os kondikat forrasztottam közvetlenül a IC101 táplábaihoz, de hatástalan volt. Az a paranormális az egészben, hogy az eredeti működő alfa verzió paneljeiből forrasztottam át az alkatrészeket. Az összes alkatrészt átvizsgáltam, nem találtam eltérést. És nem értem, hogy miért csak ebben az egy sávban és ennek is csak a felső felében jelentkezik a probléma.
(#) elektroncso válasza sany hozzászólására (») Márc 20, 2018 /
 
A végerősítő feszültségerősítése 1. Kipróbáltam, hogy a R117 kimenetre csatlakozó lábát átkötöttem a LF356 kimenetére ezzel kihagytam a tranyós végerősítőt, de az anomália ugyan úgy fennmaradt. És ami még furcsább, hogy a T105 bázisán nem mérek 185Hz-es jelet ami modulálna, nem beszélve arról, hogy a IC102 környezetének időállandója olyan magas, hogy ekkora frekit át sem tud vinni.
Én gondoltam még a LF356 belső miller-kapacitására is mint az anomália forrására (találkoztam már hasonló paranormális jelenséggel TDA2030-nál ahol külső kondenzátorral elállítva a belső miller-kapacitás értékét megszűnt az anomália, de ez ott is csak feltételezés volt), de nem tudok honnan kiindulni.
A hozzászólás módosítva: Márc 20, 2018
(#) mateatek válasza elektroncso hozzászólására (») Márc 20, 2018 /
 
Azért a C107-tel párhuzamosan raknék próba képen egy nagyobb kondit.
(#) elektroncso válasza mateatek hozzászólására (») Márc 20, 2018 /
 
A IC102 kimenete és a föld közé próbáltam 220nF-os multilayer kerámia kondenzátort tenni, de nem oldotta meg a gondom. Közvetlenül a C107-el párhuzamba nem tettem semmit.
(#) proli007 válasza elektroncso hozzászólására (») Márc 20, 2018 /
 
Hello! Az nem lehet, hogy nincs is AM moduláció, csak a digit szkóp mintavételezése miatt van ilyen kép?
(#) elektroncso válasza proli007 hozzászólására (») Márc 20, 2018 /
 
Gondoltam erre is, de "hagyományos" megjelenítésnél is látszik az ingadozó amplitúdó (ha úgy állítom be a szkópot, szépen értelmezhetően rajzolja ki a példánál maradva 70kHz-es szinuszjelet). Illetve az alfa verziónál is végeztem ilyen beállítású méréseket, ott nem tapasztaltam ilyet. De holnap ránézek analóg szkóppal meg burkológörbe detektorral is a biztonság kedvéért.
Most épp a miller-kapacitás kompenzációjának olvasok részletesebben utána, hátha megvilágosodok).
(#) pucuka válasza elektroncso hozzászólására (») Márc 20, 2018 /
 
Lehet nem ez a hiba, de én nem tennék a TL431 lábaira kondenzátort. Ha megnézed az adatlapját, a Fig.16 ábrán láthatod a stabilitási követelményeket.
Egyébként is az ilyen sönt szabályzóknak elég kicsi a dinamikus ellenállása, (meredek a letörési görbe), így nem sok értelme van a kondenzátornak.
(#) nagym6 válasza elektroncso hozzászólására (») Márc 20, 2018 /
 
Digiszkópnál ilyen bizonytalan esetekben mindig a "Peak detect" módot bekapcsolva is ajánlatos vizsgálódni, amit proli007 írt, az a mintavételezésből származó hiba -normális szkópnál- ebben a módban nincs. Mint írtad, analóg szkóp mondja biztosra mi a jelalak.
(#) elektroncso válasza nagym6 hozzászólására (») Márc 20, 2018 /
 
Ezt meg nem mondom, hogy a peak-detect mód be volt-e kapcsolva. Holnap ellenőrzöm ezt is. Arra emlékszem, hogy FFT analízist végeztem, ami kimutatta, hogy nincs felharmonikus és frekvencia csúszás. Tiszta AM van. Illetve átkapcsoltam pontrajzolásos módba, csak ott rajzolt pontot ahol ténylegesen mérést végzett. Az eredmény ugyan az. A relét is megkíséreltem kiiktatni, hátha az okoz valamit, de semmi.
De nem hiszem, hogy mérési hiba. Amit elfelejtettem mondani, hogy "kézrátétellel" ideiglenesen ki tudom ütni az anomáliát (pl. ha a frekimeghatározó kondikhoz nyúlok akkor rövid időre megszűnik az AM, majd "szépen" újrakezdődik).
Illetve még egy fontos dolog amit kifelejtettem. Bekapcsoláskor jó a jel kb. 1-2 másodpercig, majd lassan "begerjed". Olyan mintha egy kondenzátor töltődne fel. Ha kikapcsolom majd gyorsan vissza akkor szinte azonnal "begerjed", de ha kikapcsolás után hagyom állni 5 percet akkor bekapcsoláskor megint 2-3 másodpercig jó majd "begerjed". Ez okból átnéztem az IC102 környezetében lévő összes alkatrészt, de nem találtam hibát.
Illetve még egy furcsaság amin gondolkoztam leírjam-e. Kínomban leszedtem az alu búrát az optocsatolóról és ha az íróasztali lámpa 40W-os izzója rávilágított hátulról a fényellenállásra akkor ugyan ez a jelenség történt a többi sávban is. Ha lekapcsoltam a lámpát és "sötét" lett a teremben akkor újra rendbe jött minden.
Kipróbáltam azt is, hogy a LF356-ot kicseréltem TL081-re (ez akadt a kezembe), akkor pl. 100kHz-en nem jelentkezett olyan erősén az anomália csak nagyon pici amplitúdó ingadozás jelentkezett, de 70kHz környékére hangolva újra előjött az anomália. Csökkentve a frekit újra csökkenni kezdett az ingadozás.
(#) elektroncso válasza pucuka hozzászólására (») Márc 20, 2018 /
 
Köszönöm az ötletet, felírom a listára a többi holnap elvégezendő próba közé.
(#) proli007 válasza elektroncso hozzászólására (») Márc 20, 2018 /
 
Szabályzóköri hiba is lehet. De ezt az IC2 6-os lábán tudod mérni is. Akkor ott látni kell a "moduláló jelet".
(#) elektroncso válasza proli007 hozzászólására (») Márc 20, 2018 /
 
Pont ez az, tiszta +5V körüli DC jel mérhető a kimenetén, nyoma sincs a 185Hz-es jelnek. Pont ezért vagyok meglőve. Itt is próbáltam IC-t cserélni, TL071, 741 amit kipróbáltam több darabot is, újakat is. Még az invertáló lábát is próbáltam földre kötni egy 220nF-os multilayer kerámiakondival (hasra csapott érték ez akadt a kezembe). A visszacsatoló körében a 100nF-os kondi fóliakondenzátor. A neminvertáló lábán sem látni a 185Hz-es zavart. Már azt is próbáltam, hogy leválasztottam a többi áramköri részt a kimenetről, de semmi változás.
(#) sany válasza elektroncso hozzászólására (») Márc 20, 2018 /
 
Az optocsatoló hibája nem lehet? Valamiért nem jó adja át a jelet a fotoellenállásnak.
(#) elektroncso válasza sany hozzászólására (») Márc 20, 2018 /
 
Nem tudom. Ugyan ez dolgozott az alfa verzióban is ami elsőre tökéletesen működött. Elvileg semmi nem változott az alfa verzióhoz képest kivéve a paneltervet. Valahol abban lesz a hiba, de nem találom. Lehet átsiklok felette, de már vagy ötször átnéztem tüzetesen az érintett részt. Holnap az optocsatolóban a fotoellenállást is kicserélem másik típusra, hátha. Bár nem fűzök hozzá sok reményt. A legidegesítőbb az, hogy minden sávon működik, csak a harmadik sáv felső szegmensében nem. Valami köze lesz az anomáliának a "magasabb" frekvenciához, de nem tudok rájönni az összefüggésre.
(#) nagym6 válasza elektroncso hozzászólására (») Márc 21, 2018 /
 
Olyan is lehet, hogy szkóp mérőfejjel rátapintva megváltozik az áramkör működése, esetleg leáll valamilyen gerjedés, ezért nem látni. De szkóp mérőfej elvéve tovább gerjed.
(#) nagyzsak hozzászólása Márc 21, 2018 /
 
Sziasztok. Egy különleges cucc kellene.
Adott 20db optikai vevő aminek 5 v os a kimenete. Mindegyikhez kellene tartozzon egy-egy orgona hang (midi?) Ami csak addig szol amíg van optikai jel. Egyszerre több is kell tudjon szólni. A boritékba építhető mini hang kártya vagy mi. Nem jó minden indulaskor vegig játsza a felvett hangot. Egy hang 3 masodperc kell max legyen. Egy lyukszallagot kellene hanggá varázsolni
(#) Massawa válasza elektroncso hozzászólására (») Márc 21, 2018 /
 
Elsö ránézésre is nagyon rossz a NYÁK terv. Több földhurkot látok benne. A GND-k vezetése nagyon rossz, föleg egy ilyen müszerhez ( meglehetösen nagy teljesitményü fokozatok is vannak benne). Már a bal also csati (?) is felvet néhány kérdést - két GND van rajta?
Az ilyen berendezéseknél ( erösitö, jelgenerátor) igyekezni kell csillagszerüen tervezni, azaz a táp a legnagyobb teljesitményü fokozatok közelében csatlakozik a panelhez, és innen csillagszerüen ágazik el a többi fokozathoz ( nem láncszerüen felfüzve mint a kapcs rajzon).
Föleg el kell választani a digitális áramköröket, azok is csak egy helyen csatlakoznatnak a GND-hez. A kimenetek GND-jét is a csillagpontbol kell vezetni, és a GND foliáknak joval szélesebbnek kell lenni, (ha jol látom valamelyik fokozat 40-60 mA-t igényel !!!)
Következő: »»   5 / 8
Bejelentkezés

Belépés

Hirdetés
Lapoda.hu     XDT.hu     HEStore.hu