Fórum témák

» Több friss téma
Fórum » ARM - Miértek hogyanok
 
Témaindító: gtk, idő: Jún 26, 2007
Lapozás: OK   132 / 135
(#) Bakman válasza rolandgw hozzászólására (») Jan 11, 2019 /
 
Jelszó nélkül nem működik. Ha a felhasználónak nincs jelszava, akkor sem, ebben az esetben kreálni kell.
(#) rolandgw válasza Bakman hozzászólására (») Jan 11, 2019 /
 
Rendszergazda vagyok, jelszóval, csak automatikus bejelentkezés van beállítva.
(#) Bakman válasza rolandgw hozzászólására (») Jan 11, 2019 /
 
Terminal-ban ha pötyögöd a jelszavad, nem látszik semmi, csillagok sem. Beírod, Enter.
(#) rolandgw válasza Bakman hozzászólására (») Jan 11, 2019 /
 
Igen, sudo után kéri. Már egy csomó programot telepítettem így, nem volt gond.
A hozzászólás módosítva: Jan 11, 2019
(#) rolandgw válasza Bakman hozzászólására (») Jan 11, 2019 /
 
Egy utolsó kérdés és nem off-olok tovább, de a Win-re térek vissza nem az Ubuntu fórumra A chmod után kellene történni valaminek, valami kiírás a terminálban stb. Látszólag nem történik semmi.
(#) rolandgw válasza rolandgw hozzászólására (») Jan 13, 2019 /
 
sudo ./ a megoldás.
(#) don_peter hozzászólása Feb 2, 2019 /
 
Srácok, érdeklődnék, hogy esetleg ti is találkoztatok e már ilyesmivel és esetleg már meg is oldottátok a dolgot.
STM32F407-es MCU-val gyakorlók, egy projekt vége felé tartok már, és az USB-vel akadt egy kis gondom.
tm_stm32f4_usb_vcp könyvtárat használom, szépen működik a CDC, de egy gondom van, még pedig az, hogy egy idő után egyszerűen mint ha lekapcsolna, vagy mint ha idő limit lenne beállítva és ha az letellene adat csere, vagy kommunikáció nélkül, akkor halt-ra fut.
Tud esetleg ilyesmiről valaki?
Mi lehet gond? Hogy lehet mindig ébren tartani az USB, persze adatküldés nélkül.
Köszi előre is.
(#) Topi válasza don_peter hozzászólására (») Feb 2, 2019 /
 
Első körben minden Suspend módot kapcsolj ki. Van suspend interrupt is, azt se felejtsd el. Ha ilyen "jól egybegyúrt" USB libet használsz, azokban sokszor az interruptban ott rejtőzik egy power down. Még a debuggeredet is le fogja dobni, plusz ténylegesen megállítani az oszcillátort, ha a PC úgy dönt (suspend).
(#) Peppe válasza don_peter hozzászólására (») Feb 3, 2019 / 1
 
Szia,

Nekem a gyári HAL függvényekkel semmi bajom nem volt. Cube-ban felparamétereztem mindent, és utána elsőre ment. 4db hőmérő adatait küldi 100ms-es idővel. Nem találkoztam ilyen Suspend problémával.
ui: más kódját utálom használni, mert nem tudom miket rejtett el benne.
A HAL függvények azért használhatóak elég jól. Ismerem a Tilen Majerle oldalát, ami egész jó.
Én inkább egy orosz srác oldaláról szoktam bogarászni, mert ő HAL könyvárakat használ.(gugli jól fordít angolra!)
Bővebben: Link
(#) don_peter válasza Topi hozzászólására (») Feb 3, 2019 /
 
Ezeket át fogom nézni, ami bosszant, hogy Debug eszköz jelenlétével nem kapcsol ki, de ha anélkül fut a program, akkor igen..
(#) vargham válasza Peppe hozzászólására (») Feb 3, 2019 /
 
Szintén HAL. Nem hibátlan, de jól használható. A bejelentett bugokat előbb-utóbb javítják.
(#) don_peter válasza Topi hozzászólására (») Feb 27, 2019 /
 
Úgy oldottam meg, hogy ne kapcsoljon szét, hogy bizonyos idő közönként küldök ki egy byte-ot. Majd amikor kell, törlöm a buffert és kezdem az adatküldést.
Kicsit bosszantó, de egyelőre jónak tűnik. Később, ha lesz időm átnézem a programot tüzetesen.
(#) Sanyesz5 hozzászólása Márc 3, 2019 /
 
Sziasztok!

stm32f103-at használ valaki?
Egy olyan érdekességem lenne, aránylag elég nagy feszültséget mérek vele, osztón keresztül, szépen méri is, de van egy olyan érdekesség hogy valamiért lassú.
Ha leveszem pl a feszültséget az ellenállás osztó elől szép lassan kúszik csak lefelé, ez a lassú reagálás azért nem jó nekem mert pwm-el hajtok meg egy nagyfesz tápot, amit ő szabályoz, a mért feszültség alapján. Viszont ha ilyen jelenségek vannak a mérésnél, az nem a legjobb.
Mellékelem a programot is

szab.ino
    
(#) kapu48 válasza Sanyesz5 hozzászólására (») Márc 3, 2019 /
 
Úgy látom, hogy timer2-nek nincsen Prescale beállitva?
(#) Seton válasza Sanyesz5 hozzászólására (») Márc 3, 2019 /
 
Ezekben a kis oszcilloszkópokban is az STM32F103 lakozik, itt 200 kHz sávszélességet adnak meg 1 Msps mellett, ami számodra is elegendő lehet. A kapcsolási rajzot is érdemes lenne látni (nincs egy szép nagy kondenzátor a bemeneten szűrésnek?).
(#) Sanyesz5 válasza Seton hozzászólására (») Márc 3, 2019 /
 
A rajz még szerkesztés alatt, egy 100nf kondi van a bemeneten csak szűrésnek, az megmagyarázná a lassúságot ha valami nagy dög lenne ráaggatva. A mérés gyors, látszik, csak amit írtam a fura hogy olyan lomhán számolja ha változik a feszültség, na meg ha nincs, széééépen lassan fogy csak.
(#) ha1drp válasza Sanyesz5 hozzászólására (») Márc 3, 2019 /
 
A mikrokontrollerek analóg bemenetein kb maximum 10kohm eredőt javasolnak, a tiéd ennek a sokszorosa. Ilyen magas impedancia viszonyok mellett a 100nF pedig nagyon sok.
(#) kapu48 válasza Sanyesz5 hozzászólására (») Márc 3, 2019 /
 
Itt van mintának DMA + ADC 3 csatornás mérés.
Ez eredetileg 8 csatornás volt, én csökkentettem 3-ra.
A látható példa elvén akár 1 csatornára is csökkentheted a mérést.
Előnye, hogy roppant gyorsra is belőheted, ha akarod.
És a mérés nem fogyaszt processzor időt, csak a mérések kiértékelése.

Jut eszembe még kiegészítettem, hogy 32 mérést átlagoljon minden csatornán.
Az átlagolással elérheted, hogy nem szükséges szűrés a bemeneteken.
Még ezt tovább fokozhatod, ha használsz valamilyen sorba rendező algoritmust.
És a két szélsőértéket mivel valószínűleg hibásak eldobod


STM32F103:
A hozzászólás módosítva: Márc 3, 2019
(#) kapu48 válasza kapu48 hozzászólására (») Márc 4, 2019 /
 
Közben találtam egy lényeges hiányosságot az előző programban!
Itt a javítás:

  1. ...
  2. for(uint8_t i = 0; i < num_adc_pins; i++){
  3.     sumADC[i] = 0;
  4.   }
  5.   while(transfer_complete == false)//  Megvárja a DMA mérés végét. kiegészítés 84. sorba
  6.  
  7.   for(uint8_t i = 0; i < num_adc_buffer; i++){
  8. ...
(#) Sanyesz5 válasza kapu48 hozzászólására (») Márc 4, 2019 /
 
Köszi a választ, ma kipróbápom.
(#) kapu48 válasza Sanyesz5 hozzászólására (») Márc 4, 2019 /
 
Ha már kipróbálod?

Akkor itt van összehasonlítási alapnak egy a tömbök buborék rendezéssel sorba rakott, és 2-2 szélsőérték eldobásával szűrt átlagolásos megoldás.
Kíváncsi vagyok, hogy érezel e javulást a 2 módszer között?

(Megnöveltem a tömbök méretét a 4 eldobott word-al. Ennél a kis procinál sajnos óvatosan kel bánni a memória foglalásokkal.)
Multichannel_ADC_DMArendezet.ino
A hozzászólás módosítva: Márc 4, 2019
(#) don_peter hozzászólása Márc 4, 2019 /
 
Srácok, napok óta kínlódok egy hibával.
Elsőnek csak debug módban volt hajlandó működni a program, most eljutottam oda, hogy release módban működik, de most meg debug módban nem fordul le a programom.
Osztottam egy képet a hibákról, kipróbáltam egy csomó mindent, de már nem tudom mire gondoljak. Van valakinek tapasztalata, ötlete, hogy oldjam meg?

Előre is köszi az ötleteket.
(#) kapu48 válasza don_peter hozzászólására (») Márc 4, 2019 /
 
Ezt írja az ff.h-ban:
  1. /* Unicode support functions */
  2. #if _USE_LFN != 0                                          /* Unicode - OEM code conversion */
  3. WCHAR ff_convert (WCHAR chr, UINT dir)/* OEM-Unicode bidirectional conversion */
  4. WCHAR ff_wtoupper (WCHAR chr);      /* Unicode upper-case conversion */
  5. #if _USE_LFN == 3                                          /* Memory functions */
  6. void* ff_memalloc (UINT msize);   /* Allocate memory block */
  7. void ff_memfree (void* mblock);   /* Free memory block */
  8. #endif
  9. #endif


És a ffconf.h -ban kikellene választanod :
  1. #define _USE_LFN 3                // <<< Itt neked milyen érték van????
  2. #define _MAX_LFN 255
  3. /* The _USE_LFN switches the support of long file name (LFN).
  4. /

Vagy esetleg valahol felül lett definiálva az: _USE_LFN?
A hozzászólás módosítva: Márc 4, 2019
(#) kapu48 válasza don_peter hozzászólására (») Márc 4, 2019 /
 
Próbálj meg te is egy felül definiálást:
  1. #undef    _USE_LFN
  2. #define  _USE_LFN 3
(#) kapu48 válasza don_peter hozzászólására (») Márc 4, 2019 /
 
Még egy ötlet. Kapcsod ki az optimalizálást fordítás előtt.
(#) Sanyesz5 válasza kapu48 hozzászólására (») Márc 4, 2019 /
 
Mint közben kiderült, nem a mérésemmel lesz a gond. Maga a kapcsolás pwm-el állít elő nagyfeszt, 300-500 voltig, ma próbának földre raktam a bemenetet, amivel mérek ugye. Szépen leesett nullára, ahogy bekapcsolom a tápot, 0-30 között ugrál veszettül, úgy hogy földre van kötve....
(#) kapu48 válasza Sanyesz5 hozzászólására (») Márc 4, 2019 /
 
Szűrni kellene jobban a tápot.
Egyébként az nem olyan nagy ingadozás a max 4095-nek 1.3%-a.
Szokott az több is lenni.
(#) don_peter válasza kapu48 hozzászólására (») Márc 5, 2019 /
 
_USE_LFN 1
Vagy is definiáva van.
Felül definiálásr st megnézem, bár a program nezegetesenel belefodritja az adott 2 függvényt.
(#) don_peter válasza kapu48 hozzászólására (») Márc 5, 2019 /
 
Debug módban az optimalizálás 0 alapból, legalább is nekem.
(#) don_peter válasza don_peter hozzászólására (») Márc 5, 2019 /
 
Közben megoldódott a hiba.
Pontosan nem értem, hogy debug módban miért másként értelmezi a definíciókat mint release módban, de nem is érdekel. A lényeg, hogy működik már.
Következő: »»   132 / 135
Bejelentkezés

Belépés

Hirdetés
Lapoda.hu     XDT.hu     HEStore.hu