Fórum témák

» Több friss téma
Fórum » Teljesítmény -LED, powerLED (pl. Cree, Luxeon) vezérlése
Lapozás: OK   129 / 133
(#) Janszi válasza pipi hozzászólására (») Dec 1, 2019 /
 
pipi szaktárs azt akarja sugallni,hogy a 10x10 darab pontszerű fényforrás a 100w-os power led esetében okozhat homályos képet.
Megfontolandó esetleg egy hőtűrő,fénytörő homályos (üveg)lap beszerkesztése,ami lehet chip-méretű is.
(#) rockersrac válasza pipi hozzászólására (») Dec 1, 2019 /
 
Lesz lencse hozzá, a led már megérkezett, ha minden igaz a lencse is, 60° lencsét rendeltem hozzá, plusz ott van a tárgyasztal alatti lencse(vagy hogy mondják) ami fresnel lencse, és az gyűjti középre a fényt a tükrös lencsébe. Haveromnak projektoros tv fényforrását sikerült így kiváltani, szóval bár nem elterjedt, nem lehetetlen a dolog. Csak majd a középre helyezéssel kell játszani, a többi már gyalog galopp kb. Még tápegységet kell hozzá kerítenem, és hűtést(ez már ki van nézve, egy szép nagy felületű hőcsöves cpu hűtő formájában, egész lapos, szóval jó közel lesz a fénypont az eredetihez. Majd ha kész mutatok képeket.
(#) duke válasza rettung hozzászólására (») Dec 1, 2019 /
 
Azok a skory féle áramgenerátorok valószinűleg jók lennének. Illetve az egyik biztos, amit régebben megépítettem. Ezt a "kapcsolóüzemü áramgenerátor szabályozhato, kb. 4A-ig" nevűt ajánlanám, azóta abból még egyet csináltam, mind a kettő gond nélkűl működik. Ha ezt pontosan megépíted, a rajz alapján, akkor szerintem működni fog. Nem az ott lévő nyáktervet használtam, mert nagy részt smd alkatrészekből építettem, ezért átterveztem, de igy is gond nélkül működött, tehát a kapcsolás jó.
(#) sitto hozzászólása Dec 2, 2019 /
 
Sziasztok!

Már egy jó ideje küzdök egy LED vezérlővel több-kevesebb sikerrel. Inkább kevesebbel.
Most már van egy félig-meddig működő verzióm. Ezzel egy XHP-70 ledet (6V 4,8A) szeretnék hajtani.
A MAX 16820 ic-nek a pwm jelet az attiny szolgáltatja 25%,50% és 100% kitöltéssel.
Eddig működik is a dolog, a kapcsolót nyomogatva tudom váltogatni az üzemmódokat és világít a led.
Viszont ha a tápfeszt kb. 7.5 v-ra növelem akkor lekapcsol az egész. A gombot nyomogatva csak villan egyet a led de bekapcsolni addig nem lehet amíg a tápfeszt le nem csökkentem.

Gyengébb leddel is ez a helyzet csak a tápfesz magasabb lehet (áramkorlátozó ellenállás változik a led függvényében).

Van valakinek ötlete, hogy mi lehet a baj?
Mellékeltem a kapcsolást.
A hozzászólás módosítva: Dec 2, 2019

driver_V7.JPG
    
(#) pipi válasza sitto hozzászólására (») Dec 2, 2019 /
 
A Max IC VCC-je nem lehet hogy túl pici áramot bír, a tiny lekajálja az áramot, ettől a max letilt?
Próbáld rendes külön tápról a tinyt
(#) sitto válasza pipi hozzászólására (») Dec 3, 2019 /
 
A max 16820 papír szerint 10mA áramot tud (5V 10mA), ettől szerintem az attiny nagyságrendekkel kevesebbet fogyaszt és a probléma csak nagyobb tápfesznél jelentkezik.

Az XHP70 lede esetébena vezérlő szerintem még nem tudja stabilizálni az áramot az alacsony tápfesz miatt, így a tápfesz emelésével 100% pwm-nél nő az árramfelvétel, majd 7,5V körül lekepcsol.

Kisebb teljesítményű ledet használva (XM-L2 3V 3A) az áram már stabil, ne növekvő tápfesz esetén ez is lekapcsol, csak jóval magasabb bemenő fesz esetén.

Annyit vettem észre, hogy 7V fölött a pwm jel elkezd zajosodni.

Mellékeltem egy korábbi nyáknál készült mérést, gyanítom, hogy most is hasonló lehet de ennél még nem mértem.
A hozzászólás módosítva: Dec 3, 2019

image.png
    
(#) pipi válasza sitto hozzászólására (») Dec 3, 2019 /
 
Azért próbáld csak ki...
Nagyobb fesz, ua. áram -> nagyobb melegedés -> lekapcsolhat.
Aztán ott lehet még valamilyez zavarás a tápon, amitől a proci meghülyül.
(#) sitto válasza pipi hozzászólására (») Dec 3, 2019 /
 
Köszi!

Átterveztem közben a nyákot és beraktam egy LDO-t külön a procinak.
2-3 hét mire megjön kínából.
Addig is egy L7805-el csinálok külső tápot a procinak vagy kiveszem és egy arduinoval küldöm a pwm jelet a IC-nek.
(#) sitto válasza pipi hozzászólására (») Dec 3, 2019 /
 
Az ötlet jó volt.
A proci hülyül meg.

Felhajtottam a proci táp lábát és a nyákra rápatkoltam egy 7805 fesz.stabilizátort és ez adta a tápot a procinak. Semmi nem változott, ugyan úgy lekapcsol, sőt kisebb feszültségnél.

Aztán gondoltam most már mindegy lássuk a füstöt. Kiforrasztottam a procit és a 7805  kimenetét rákötöttem a 16820 pwm bemenetére. Ez olyan mintha megkapná a 100% 5V pwm jelet.És láss csodát működik.
Eddig kb.7 voltnál kikapcsolt, most 12-ig nyugodtan lehet tolni, tovább nem mertem mert 5A fölé megy az áram a led meg drága és csak 1 van.

Na most mit csináljak vele?
A hozzászólás módosítva: Dec 3, 2019
(#) pipi válasza sitto hozzászólására (») Dec 3, 2019 /
 
Szűrd meg a proci tápját, ha a proci kimenetét ha lekötöd nézd meg hogy magában is kifagy-e,
proci és max kozé tegyél ellenállást
cserélj procit...
(#) sitto válasza pipi hozzászólására (») Dec 3, 2019 /
 
A procit nem cserélgettem ,minden nyákra újat tettem és mindig lekapcsolgatott a cucc adott tápfesz fölött.

Amikor a 7805 -ről kapta a tápot akkor azon volt egy 0.33µF és egy 0,1 µF kondi. Akkor is lekapcsolt.

Egyik korábbi verzióban volt egy 470 ohmos ellenállás a proci kimenete és a 16820 között.
Az sem segített.
(#) pipi válasza sitto hozzászólására (») Dec 3, 2019 /
 
Ha ez több cuccal egyformán rossz, akkor nyiván tervezési hiba. Valahol óriási zaj keletkezik, vagy valami fűt. Szkópolni kéne.
A részegységeket külön kell választani, külön vizsgálni a működést, úgy is hogy a másik közben "áramtalan"
(#) sitto válasza pipi hozzászólására (») Dec 3, 2019 /
 
Könnyen lehet, hogy tervezési hiba de mi lehet az?
Néhány alkatrész az egész nagyon nincs mit szétválasztani.
A proci önmagában működik és a jelek szerint a 16820 is.

Zaj biztosan van mert kapcsoló üzemű a cucc.

Ami a szkópon látszi, hogy ha világít a led akkor annak áramfelvételétől függetlenül a proci felé menő táp 7V felett elkezd zajosodni.
7.1V-nál még sima
7.5V-nál már zajos, majd fölötte lekapcsol.

Még annyit csináltam, hogy leforrasztottam a procit a nyákról és k 5cm vezetékekkel kötöttem vissza.

Ha nem világít a led akkor egyenletes a tápfesz.
A hozzászólás módosítva: Dec 3, 2019
(#) Kovidivi válasza sitto hozzászólására (») Dec 3, 2019 /
 
Több dolog jutott eszembe:
- 3-4A-ról írsz. Mi a betápod? Nem zuhan össze?
- Az átlagáram 3-4A, de mennyi a csúcs?
- az AVR-ben vannak BODE fuse-k is. Az 4V-on áll esetleg? Mert ha igen, akkor azonnal resetel az AVR! Be lehet 2V-ra is állítani, vagy ki lehet kalcsolni!
- az AVR lábánál van 10uF?
- az AVR tápját diódával és kondival leválasztani a betápról? Ekkor meg sem érezné a hullámzást.
- vezetékek a betáptól a LED-ig vastagok?
- az AVR gnd-je véletlenül nem ott van, ahol a dc-dc meg tudja rángatni? Külön GND-t húzni az AVR-nekn
- Képet rakhatnál fel az egész elrendezésről!
(#) sitto válasza Kovidivi hozzászólására (») Dec 3, 2019 /
 
A táp egy UNI-T laportáp. Ezt tudnia kell.
4.8A átlagra van tervezve.
A led vezetékein lakatfogóval 4.6A -t mértem.
Elméletileg 1A körüli ingadozása van, de ezt nem tudom megmérni.
Amikor a procit kihagytam és a 16820 direktben kapta az 5V-ot a DIM lábon, akkor felment 5.2A-ig, ekkor viszont a tápfesz már 12V felett volt. A 4.6A-t 7.4-7.6V tápfesz között tudom mérni, utána ugye lekapcsol.
Vezetékek a táptól a nyákig 20 AWG, ennek elégnek kell lennie, ahogy a proci mentes verzióban elég is volt.

arduino ide-vel programozok, ott a BOD 4.3V-ra van állítva. Erre gondoltál?
(#) pipi válasza sitto hozzászólására (») Dec 3, 2019 /
 
Ha látod a zajos tápot, akkor min csodálkozol, ezt kell megoldani!
jópár amper rángatásához pár mikró kondit teszel be a tápra, az egész meg lóg jó hosszú vezetéken?
(#) Kovidivi válasza sitto hozzászólására (») Dec 4, 2019 /
 
Pontosan! Bod level-t kapcsold ki, vagy rakd a legalacsonyabbra!
(#) sitto válasza pipi hozzászólására (») Dec 4, 2019 /
 
Csak ott a bibi, hogy amikor a 7805-től kapta a tápot a proci akkor is lekapcsolt a led.
A 7805 kimenetén pedig ez a zaj nem mérhető.
(#) sitto válasza Kovidivi hozzászólására (») Dec 4, 2019 /
 
Ha a BOD 2.7V akkor is lekapcsol.
Megpróbálom a BOD-ot kikapcsolni. Hátha...
(#) sitto válasza Kovidivi hozzászólására (») Dec 4, 2019 /
 
Idézet:
„- az AVR tápját diódával és kondival leválasztani a betápról? Ekkor meg sem érezné a hullámzást.”


Idézet:
„az AVR lábánál van 10uF?”


Erről küldenél egy vázlatot?

Átterveztem a nyákot ismét, külön GND megy a procinak és egy 5V LDO.
A hozzászólás módosítva: Dec 4, 2019
(#) Kovidivi válasza sitto hozzászólására (») Dec 4, 2019 /
 
A betápoddal soros dióda (mondjuk SS34), majd ezután egy kondi (helyfüggő, 10µF-tól felfele) a GND-re., és innen táplálni az AVR-t (vagy a stabilizátorát). A LED-ed és a meghajtója pedig közvetlenül a betápról táplálva. Ez megakadályozza, hogy ha beesik a betápod, ne tudjon az áram az AVR-től visszafelé folyni (a betáp és a LED felé), így az AVR még akkor is kap tápot egy ideig, ha elvágod a betáp vezetéket (kondiban tárolt töltés). Így egy diódával el van szeparálva a két egység.

Az AVR táplábainál a 100nF fontos, vele párhuzamosan 10µF pluszban jöhet, ha van helyed. Szerintem rajz nélkül is megérted.
A hozzászólás módosítva: Dec 4, 2019
(#) sitto válasza Kovidivi hozzászólására (») Dec 5, 2019 /
 
Közben méregettem és kísérleteztem egy kicsit.
Valóban táp problémának tűnik, a táp - és a proci gnd lába között is mérhető a zaj.
A proci táp és gnd lábát egyszerűen összekötöttem egy 47µF elektrolit kondival.
Ekkor már tudtam emelni a tápfeszt, nem kapcsolt le csak akkor ha a pwm kitöltése 100%

Ezt még nem tudom, hogy mitől lehet.
A hozzászólás módosítva: Dec 5, 2019
(#) sitto válasza Kovidivi hozzászólására (») Dec 9, 2019 /
 
Idézet:
„A betápoddal soros dióda (mondjuk SS34), majd ezután egy kondi (helyfüggő, 10µF-tól felfele) a GND-re., és innen táplálni az AVR-t (vagy a stabilizátorát). A LED-ed és a meghajtója pedig közvetlenül a betápról táplálva. Ez megakadályozza, hogy ha beesik a betápod, ne tudjon az áram az AVR-től visszafelé folyni (a betáp és a LED felé), így az AVR még akkor is kap tápot egy ideig, ha elvágod a betáp vezetéket (kondiban tárolt töltés). Így egy diódával el van szeparálva a két egység.

Az AVR táplábainál a 100nF fontos, vele párhuzamosan 10µF pluszban jöhet, ha van helyed. Szerintem rajz nélkül is megérted.”



Ezt még nem próbáltam de kicsit még kísérleteztem:

Sikerült megduplázni a bemenő fesz. értékét anélkül, hogy kikapcsolgatna a cucc. Most 15V fölött kapcsol csak ki, de másképp mint eddig.

A proci tápellátásával van a gond!


Rápatkoltam egy 7805-öt a nyákra, közvetlenül a bemenő táp vezetékeinek közelébe
Kiforrasztottam a procit a helyéről és "megdrótoztam" a lábait
proci gnd 7805 gnd-re kötve
proci vcc 7805 out-ra kötve
proci pb0 max16820 DIM-re kötve a nyákon keresztül, R2-t kiforrasztottam, helyette nyákon kívül pb0 100k-val 7805 gnd-re kötve
proci pb3 és kapcsoló p1 egy 1k ellenállással a nyákon kívül 7805 out-ra kötve
p2 kapcsoló láb 7805 gnd-re kötve

Így megpróbáltam külön tápot kreálni a procinak.

Na most, 15V-ig működik faszán a cucc, 15V felett viszont végigszalad az összes üzemmódon és kikapcsol.
Tehát olyan mintha valami a proci pb3 lábát még gnd-re rángatná mintha nyomkodnám a kapcsolót. De a kikapcsolt állapotban megáll, nem megy át végtelen ciklusba és
kapcsolgat.
Szkópon látszik, hogy változik a pwm jel szélessége az automatikus kapcsolgatás során. Változik a fényerő is, ez így rendben is van.
Viszont a pb3 lábnál azt nem sikerült kimérni, hogy v.mi gnd-re húzná mint amikor megnyomom a gombot.
Ha én nyomkodom a gombot az mérhető de amikor önmagától kapcsolgat az nem látszik a szkópon.

Egyébként a 7805 kimenete is kissé zajosabb ha világít a led.

És még egy érdekes dolog van, ha a szkóp szondát rácsíptetem a proci pb3 lábára (csipesz gnd-re), akkor bőven 15V fölé lehet menni, nem kapcsol ki, nem kapcsolgat. Működik úgy ahogy kellene.

A nyákot átterveztem úgy, hogy a proci saját tápot kapjon agy ldo-val, a logic és a power gnd csak a betáp mínusznál találkozik. viszont a 7805-ös kísérletből úgy tűnik, hogy ez nem biztos hogy elég lesz.
(#) Kovidivi válasza sitto hozzászólására (») Dec 9, 2019 /
 
Nem tudom, hogy a pb3-on a gomb van-e, vagy az adja a PWM jelet a másik IC-nek, de ha raknál egy kis terhelést mindkettőre, akkor nem lennének olyan érzékenyek!
A PWM kimenetre egy 2k2-10k-t raknék a GND-re, a gomb bemenetét meg nem hagynám, hogy szabadon lógjon bárhova is. Felhúzó ellenállást elfelejteném, az 100-200k értékű, vagy annál is nagyobb. Lemennék 10K-ig, ezzel húznám fel 5V-ra, a kapcsoló pedig GND-re kapcsolná, rakhatnál oda is egy kondit (RC tagot létrehozva), hogy ha valami zavar mégis jönne, akkor a kondi elsímítja azt is.
Simán lehet, hogy a LED meghajtása során akkora zaj van a környezetében, hogy az AVR bemeneteit is összezavarja. Mondjuk ezen nem is csodálkozok, 4A-es dc-dc konverter azért zajon rendesen.
A uC nem használt lábai is legyenek kimenetek, és GND-re állítsd őket, így a zajt elnyelik (plusz rakhatsz rájuk 100Ohm-ot a GND-re, biztos ami tuti). Alapból ugyanis bemenet mind, ha nem állítasz be semmit.
A módosított kapcsolási rajzot felrakhatnád. Ha jól emlékszem, fénykép még nem lett felrakva a cuccodról, pedig sokkal több infót tartalmazna, mint a szöveg, amit leírsz. Te ugyanis csak azt tudod leírni, amit értesz is. Viszont a hibát nem érted (még mi se pontosan), de ha látnánk a szituációt, lehet egyből beugrana valami (pl. breadboardon próbálod összerakni az egészet, hogy működik-e. Na arra azonnal ugranék, hogy 50mA felett el kell felejteni...) .

Jó volna, ha a kapcsolási rajzra betűk helyett feszültség szinteket írnál, pl. betáp 7-15V, mert most van egy VCC-d, meg az IC VCC lába megy az AVR-hez. Egyszerűsítsd le, mert így nagyon zavaró.
Az IC DRV lábára nem kell lehúzó ellenállás? A DIM-re én 100k helyett 4k7-t tennék.
A PB3-on az 1K-t látom, az 5V-on az már 5mA-rel terheli be a betápod, ami csak 10mA-t tud!
A headerek helyett is rakj be kapcsolót, legalább addig, míg feltöltöd ide. Mi honann tudjuk, hogy a header 1*1P mi lehet?
A hozzászólás módosítva: Dec 9, 2019
(#) Kovidivi válasza Kovidivi hozzászólására (») Dec 9, 2019 /
 
A 7805 elé minimum 100uF, utána maximum 10µF és vele párhuzamosan 100nF.
A 7805-nek is van minimális terhelése, pár mA (adatlapban utána tudsz nézni). Vagy egy LED, vagy egy ellenállást kell beraknod, ha nincs helyed, mert az AVR-rel nem biztos, hogy ezt a minimális fogyasztást garantálni tudod, és akkor zajos lesz a 7805 kimenete, gerjedhet, stb.
(#) ecchphoto hozzászólása Márc 9, 2020 /
 
Sziasztok! LM2596-ot alkalmazó áramkorlát beállítását lehetővé tevő step-down elektronikát lehet pwm-kapcsolgatni az LM2596 5-ös lábán?
Idézem a pin descriptiont
"pin5: on/off.
It allows the switching regulator circuit to be shut down using logic level
signals, thus dropping the total input supply current to approximately 80 mA.
The threshold voltage is typically 1.4 V. Applying a voltage above this value
(up to +Vin) shuts the regulator off. If the voltage applied to this pin is lower
than 1.4V or if this pin is left open, the regulator will be in the "on" condition"

E lapka 150kHz-en kapcsol amúgy is, ezt szeretném arduinoval még "utó"kapcsolagni 980Hz-en.
A hozzászólás módosítva: Márc 9, 2020
(#) Saggitarius válasza ecchphoto hozzászólására (») Márc 30, 2020 /
 
Az On/Off pin nem arra szolgal, hogy "gyorsan" ki-be kapcsolgasd az egesz rendszert. A feedback labon keresztul megoldhato, ha a beallithato tipusod van.
(#) melorin hozzászólása Ápr 12, 2020 /
 
Sziasztok!
Tudnátok segíteni abban, hogy tudnék építeni, vagy olcsón beszerezni olyan LED meghajtót ami elég magas frekvenciájú PWM jellel vezérli/dimmeli a LED-et ahhoz, hogy ne vibráljon lekamerázva se? Állítólag 25KHz kell ehhez minimum.
És milyen LED szalagot lenne érdemes vennem, ami bírja is az ilyen vezérlést?
(#) Gafly válasza melorin hozzászólására (») Ápr 12, 2020 /
 
Ez esetben miért nem használsz izzót? Annyit talán nem kamerázol, hogy a fogyasztás legyen a fő szempont...
(#) nedudgi válasza melorin hozzászólására (») Ápr 12, 2020 /
 
PT4115 vagy ME2215 alapú meghajtó működhet elképzelésed szerint.
Következő: »»   129 / 133
Bejelentkezés

Belépés

Hirdetés
Lapoda.hu     XDT.hu     HEStore.hu
Az oldalon sütiket használunk a helyes működéshez. Bővebb információt az adatvédelmi szabályzatban olvashatsz. Megértettem